Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 45920

Summary: portage should translate encoded values in filenames (%20 == ' ')
Product: Gentoo Linux Reporter: Christophe LEFEBVRE <chtof62>
Component: Current packagesAssignee: Portage team <dev-portage>
Status: VERIFIED LATER    
Severity: enhancement    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Christophe LEFEBVRE 2004-03-27 12:31:40 UTC
Hi !

It seems that we can't use spaces in SRC_URI when we create an ebuild.
I have try to use "%20" or "\ " instead of a space and I continue to have an error.

Then, how can I use a space in a SRC_URI ? Or can you improve the ebuild system to support spaces in SRC_URI ?

Reproducible: Always
Steps to Reproduce:
1. Use a SRC_URI with spaces in an ebuild. For example : http://www.kde-look.org/content/files/10039-Deep%20Plastik.kcsrc
2.
3.

Actual Results:  
I have an error when I do an "ebuild myebuild.ebuild digest"

Expected Results:  
To download the file and do a MD5sum.
Comment 1 Marius Mauch (RETIRED) gentoo-dev 2004-06-09 20:08:26 UTC
hmm, spaces are used as seperators, I don't see a good way to support this. %20 might work for wget, but not for the internal portage functions (or should we use urldecode ?).
Comment 2 SpanKY gentoo-dev 2004-06-09 22:10:19 UTC
yeah, the spaces arent valid URI's anyways :)

use %20's
Comment 3 Christophe LEFEBVRE 2004-06-10 13:05:45 UTC
I agree but Portage seems to do not support "%20" in URI...
Comment 4 Nicholas Jones (RETIRED) gentoo-dev 2004-08-13 22:52:42 UTC
Spaces aren't supported... but we probably could add urldecode to work it out.
Feel free to post a patch.
Comment 5 Jason Stubbs (RETIRED) gentoo-dev 2005-07-28 07:26:08 UTC
Putting a hold on feature requests for portage as they are drowning out the 
bugs. Most of these features should be available in the next major version of 
portage. But for the time being, they are just drowning out the major bugs and 
delaying the next version's progress. 
 
Any bugs that contain patches and any bugs for etc-update or dispatch-conf can 
be reopened. Sorry, I'm just not good enough with bugzilla. ;) 
Comment 6 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 12:52:11 UTC
Consider this closed as WONTFIX (the problem is the local filename, not the url).