Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 458980

Summary: net-print/cups-1.6.1 fails to collate in printer
Product: Gentoo Linux Reporter: James <cctsurf>
Component: [OLD] PrintingAssignee: Printing Team <printing>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 463014    

Description James 2013-02-24 13:04:22 UTC
I have a number of printers which can collate in the printer, and I am often printing numerous copies of graphical items, which is incredibly slow under software collation.  Unfortunately, it seems impossible to do this under cups-1.6.1.  I had downgraded to 1.5.3, under which hardware collation worked fine, but now that kde 4.10 requires >1.6, I have installed it.  I've been using windows under virtualbox to print my multiple copies (talk about a binary printer driver)
I have reinstalled my ppds, I have moved to hplip ppds, but nothing works

Reproducible: Always

Steps to Reproduce:
1. emerge cups 1.6.1
2. set the printer control to collate in printer
3. wait 5 minutes between prints for 1000 copies
Actual Results:  
wait 5 minutes between prints for 1000 copies, beat head against wall, curse, move to windows for printing

Expected Results:  
Print multiple copies quickly and painlessly (these printers can print up to 32 pages/minute

emerge --info
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.16.0, 3.8.0-gentoo x86_64)
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1045T_Processor-with-gentoo-2.2
KiB Mem:     8168848 total,   7707868 free
KiB Swap:    5242876 total,   5242876 free
Timestamp of tree: Sat, 23 Feb 2013 20:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo MythTV-0-26-fixes Home
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/mnt/nfs_portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.netnitco.net http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.mirrors.tds.net/gentoo http://www.cyberuse.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/mnt/nfs_portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/nfs_portage"
PORTDIR_OVERLAY="/var/lib/layman/mt-mythtv /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aacs acl acpi alsa amd64 audiofile avahi avi bluetooth bluray branding bzip2 cairo ccache cdda cddb cdio cdr cdrkit cli consolekit cracklib crypt css cups cxx dbus declarative divx4linux dlloader dri dts dv dvb dvd dvdnav dvdr dvdread emboss enca encode exif extras fam ffmpeg firefox flac fontconfig fortran g3dvl gdbm gif gimp glut gpm gtk gzip iconv icu ieee1394 imagemagick java jpeg json kde kerberos kipi kontact ladspa lame lcms ldap libnotify live lm_sensors lv2 mad melt midi mjpeg mmx mmx2 mmxext mng modules mp2 mp3 mp4 mpeg mplayer mpm-worker mtp mudflap multilib musepack mythtv ncurses nls nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl openmp pam pango pcre pda pdf pdflib phonon plasma png policykit posix ppds pulseaudio qt3support qt4 readline scanner sdl semantic-desktop session smp snmp sockets spell srt sse sse2 ssl startup-notification subtitles svg swat szip tcpd theora threads tiff truetype udev udisks unicode upower usb vcd vdpau vim-syntax vorbis webkit wxwidgets x264 xanim xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="hda_intel usb_audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport presenter-console presenter-minimizer" LINGUAS="en en_US" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="hp umax" USERLAND="GNU" VIDEO_CARDS="nvidia ati vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 James 2013-03-10 18:48:05 UTC
I'm not certain that this is related, but it appears that Cups 1.6 shakes all sorts of things up because Cups is getting more and more apple oriented all the time:  http://lwn.net/Articles/485617/
I would guess that https://bugs.gentoo.org/show_bug.cgi?id=457574 almost certainly is related...
The changes seem to be fairly far reaching, I really wonder if we can come up with a patch to allow kde 4.10 to build with cups-1.5 instead of 1.6.
Comment 2 Andreas K. Hüttel gentoo-dev 2013-05-11 21:49:31 UTC
Did you test cups-1.6.2 already? (There are some remarks about jcl in the changelog that might be relevant, but cups upstream bug database servers are offline right now so I cannot check in more detail.)
Comment 3 James 2013-05-12 03:33:42 UTC
I have been using cups-1.6.2 for a while now, but there was no change until today with the installation of cups-filters-1.0.34.  I should also note that I continue to get an error at the printer that started with cups-1.6 "40 eio bad transmission" (I do not get this with any other operating system or with cups 1.5)
Comment 4 Andreas K. Hüttel gentoo-dev 2013-05-13 20:08:58 UTC

*** This bug has been marked as a duplicate of bug 434940 ***