Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 458290

Summary: sys-apps/groff-1.21, sys-apps/man-1.6g: Japanese manpages illegible
Product: Gentoo Linux Reporter: Roman Žilka <roman.zilka>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also:
Package list:
Runtime testing required: ---

Description Roman Žilka 2013-02-19 13:15:00 UTC
When I run:
# export LC_ALL="ja_JP.eucJP"
# export LANG="ja_JP.eucJP"
# man bash

... the output is illegible. "man" issues this command to produce the manpage:

sh -c (cd "/usr/share/man/ja" && (echo ".ll 10.4i"; echo ".nr LL 10.4i"; echo ".pl 1100i"; /bin/cat '/usr/share/man/ja/man1/bash.1'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/groff -Tnippon -mandocj | /usr/bin/less)

The same bug happens for s/eucJP/EUC-JP/ or .../UTF-8/. The manpages are positively written in EUC-JP, though.

Happens with both the latest and previous stable man-pages-ja.

# grep -i ja /etc/locale.gen 
ja_JP UTF-8
ja_JP.UTF-8 UTF-8

Reproducible: Always

# emerge --info man groff man-pages-ja
Portage (hardened/linux/amd64, gcc-4.6.3, glibc-2.15-r3, 3.7.5 x86_64)
                        System Settings
System uname: Linux-3.7.5-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
KiB Mem:     4022828 total,   1918912 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 19 Feb 2013 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mavx -maes -mpclmul -mpopcnt -mcx16"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mavx -maes -mpclmul -mpopcnt -mcx16"
FCFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mavx -maes -mpclmul -mpopcnt -mcx16"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nodoc noinfo parallel-fetch parallel-install protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch usersync"
FFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mavx -maes -mpclmul -mpopcnt -mcx16"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_EXTRA_OPTS="--sparse --itemize-changes --human-readable --stats --compress --compress-level=9"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acpi aes-ni alsa amd64 avx avx256 bash-completion berkdb bluetooth bzip2 cddb cjk cli cracklib crypt cxx dri encode ffmpeg flac fontconfig ftp gdbm geoip gif gnutls gps gzip hardened hddtemp iconv icu idn imap javascript jpeg jpeg2k justify libass lm_sensors lzma lzo matroska mbox mime mms mmx modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz ncurses nls nocd nptl ogg opengl pam pax_kernel pcre pda pdf png postscript quicktime raw readline recode session smp sockets sound spell sse sse2 sse2_4way sse3 sse4_1 ssl ssse3 svg syslog threads truetype udev unicode urandom usb v4l vdpau videos vim-syntax vorbis wifi x264 xcomposite xosd xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en cs sk ja" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="i965 intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

sys-apps/man-1.6g was built with the following:
USE="lzma (multilib) nls test (-selinux)" ABI_X86="64"

sys-apps/groff-1.21 was built with the following:
USE="X (multilib) test -examples" ABI_X86="64" LINGUAS="ja"

app-i18n/man-pages-ja-20111020 was built with the following:
USE="(multilib) test" ABI_X86="64"
Comment 1 Naohiro Aota gentoo-dev 2013-02-19 18:12:22 UTC
Did you invoked your terminal with LANG="ja_JP.EUC-JP"? If not, it is expected that the terminal cannot decode man's output properly.

# But anyway, I personally recommend to use man-db instead. sys-apps/man's Japanese patch is quite dated.
Comment 2 Roman Žilka 2013-02-19 18:25:50 UTC
LANG has no effect, but when I run:

$ export LC_ALL="ja_JP.EUC-JP"
$ xterm

then in the new terminal I see "man bash" in correct Japanese. I didn't know running the xterm with ja_JP locale was necessary, thanks for the hint.

Also, please bump man-pages-ja to -r1 and change pkg_postinst() appropriately. It currently instructs to change LANG and doesn't mention the need for a new terminal.
Comment 3 Roman Žilka 2013-02-19 18:33:38 UTC
(I take back the new terminal warning - that's just my faulty brain; ordinary people will remember that UTF-8 is not EUC-JP.:) )