Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 457994

Summary: livedvd-amd64-multilib-20121221.iso: kernel panic when booting in kvm with "-cpu host"
Product: Gentoo Release Media Reporter: Stijn Tintel <stijn+gentoo>
Component: LiveCD/DVDAssignee: Team Anniversary <ten>
Status: RESOLVED FIXED    
Severity: major CC: mail
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: part of the kernel panic
part of the kernel panic

Description Stijn Tintel 2013-02-17 16:06:33 UTC
Created attachment 339148 [details]
part of the kernel panic

Yesterday I tried to install Gentoo in a KVM VM, using livedvd-amd64-multilib-20121221.iso. This didn't work, because of a kernel panic very early during boot.

This seems to be a known issue, caused by running kvm with "-host cpu", and not having KVM guest options enabled in the kernel config. Booting the same ISO with "-host kvm64" works just fine.

This seems to be a known issue, see https://bugs.launchpad.net/qemu/+bug/1037675 for example. The solution to be able to boot with "-cpu host", is to enable these kernel options, so please enable these in the next livedvd iso:

CONFIG_KVM_CLOCK=y
CONFIG_KVM_GUEST=y
CONFIG_PARAVIRT=y
CONFIG_PARAVIRT_CLOCK=y
Comment 1 Stijn Tintel 2013-02-17 16:09:09 UTC
Created attachment 339152 [details]
part of the kernel panic
Comment 2 slick 2013-03-02 07:45:49 UTC
I can confirm this. Same here.
Comment 3 Fernando (likewhoa) 2013-03-08 04:24:17 UTC
this is added to next livedvd. thanks for reporting.