Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 456990

Summary: media-libs/lensfun-0.2.7 version bump
Product: Gentoo Linux Reporter: Mario Kicherer <dev>
Component: [OLD] LibraryAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: enhancement Keywords: PATCH
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://lensfun.berlios.de/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: lensfun-0.2.5_p153-build.patch
lensfun-2.7.ebuild.patch

Description Mario Kicherer 2013-02-12 20:08:25 UTC
Version 0.2.7 was released. Looks like the gentoo patches have not been included upstream, I had to modify the build.patch and it looks like the pc.patch is not required anymore. Afterwards, it works for me on AMD64.

Reproducible: Always
Comment 1 Mario Kicherer 2013-02-12 20:09:31 UTC
Created attachment 338726 [details, diff]
lensfun-0.2.5_p153-build.patch

Patched patch
Comment 2 Siuchung Cheung (Clement) 2013-03-04 05:01:06 UTC
Works for me. However, there's a warning about the missing auxfun patch:
 * QA: File or directory "/net/air.port0.org/portage/media-libs/lensfun/files/lensfun-0.2.7-auxfun.patch" does not exist.
 * QA: Check your PATCHES array or add missing file/directory.

Looks like the 0.2.6 patch still applies if you refer to that version directly. Also, you might want to rename your new build patch so it doesn't break the 0.2.6 ebuild. This applies cleanly for me:
--- lensfun-0.2.6.ebuild        2013-02-07 14:31:20.000000000 -0800
+++ lensfun-0.2.7.ebuild        2013-03-03 20:53:44.953719771 -0800
@@ -24,9 +24,8 @@ DEPEND="${RDEPEND}
        doc? ( app-doc/doxygen )"
 
 PATCHES=(
-       "${FILESDIR}"/${P}-auxfun.patch
-       "${FILESDIR}"/${PN}-0.2.5_p153-build.patch
-       "${FILESDIR}"/${PN}-0.2.5_p153-pc.patch
+       "${FILESDIR}"/${PN}-0.2.6-auxfun.patch
+       "${FILESDIR}"/${PN}-0.2.7-build.patch
        )
 
 DOCS=( README docs/mounts.txt )
Comment 3 Mario Kicherer 2013-03-23 13:05:22 UTC
Created attachment 342982 [details, diff]
lensfun-2.7.ebuild.patch

Ebuild patch from 2.6 to 2.7
Comment 4 Markus Meier gentoo-dev 2013-03-23 16:59:37 UTC
bumped in cvs, thanks for the report and patches!

+*lensfun-0.2.7 (23 Mar 2013)
+
+  23 Mar 2013; Markus Meier <maekke@gentoo.org> +lensfun-0.2.7.ebuild,
+  +files/lensfun-0.2.7-build.patch:
+  version bump by Mario Kicherer in bug #456990
+
Comment 5 Nikoli 2013-03-23 20:42:38 UTC
I think the bump was done wrong, why ebuild wants python-2.6 and does not support python-2.7? Previous versions build fine with python-2.7.
Comment 6 Markus Meier gentoo-dev 2013-03-23 20:59:22 UTC
(In reply to comment #5)
> I think the bump was done wrong, why ebuild wants python-2.6 and does not
> support python-2.7? Previous versions build fine with python-2.7.

+  23 Mar 2013; Markus Meier <maekke@gentoo.org> lensfun-0.2.7.ebuild:
+  restore python-2.7 support
+
Comment 7 Mario Kicherer 2013-03-24 10:49:06 UTC
Could you tell me which ebuild failed due to python? I did remove the python parts from the ebuild as - afaik - it was only required for the build system before they switched to cmake.
Comment 8 Mario Kicherer 2013-03-24 10:54:40 UTC
This was my proposal for the ebuild: https://github.com/anyc/anyc-overlay/blob/master/media-libs/lensfun/lensfun-0.2.7.ebuild Would be nice if someone could tell me if it fails.