Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 455498

Summary: dev-db/tora-2.1.4 version bump
Product: Gentoo Linux Reporter: Small_Penguin <dark.shadow>
Component: Current packagesAssignee: Michael Haubenwallner (RETIRED) <haubi>
Severity: normal Keywords: EBUILD, PATCH
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: tora-2.1.4-ext-loki.patch

Description Small_Penguin 2013-02-04 20:41:42 UTC
The in-tree version (2.1.3-r2) is very buggy; It crashes everytime you close a tab or the window, sometimes leaving a process running (tested with oracle db connection, but maybe it happens with a mysql db connection too). This makes it pretty unusable, I wonder why no one else complains?

The current SVN version fixes all these problems.

Update is quite easy: Check out the current SVN (I build revision 4561), drop all patches (the GCC-4.7 is no longer needed, and I'll upload an updated version of the external loki patch, which needed only minor fixes.

Reproducible: Always
Comment 1 Small_Penguin 2013-02-04 20:42:26 UTC
Created attachment 337932 [details, diff]
Comment 2 Small_Penguin 2013-02-04 20:43:45 UTC
Created attachment 337934 [details]

Updated ebuild, I called it tora-2.1.4 but that might need to be changed.
Comment 3 Small_Penguin 2013-02-04 20:46:03 UTC
Ah yes, you should simply pack the SVN working tree you checked out into a bz2 file, I modified the ebuild to look for tar.bz2.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-02-05 12:28:18 UTC
Comment on attachment 337934 [details]

--- tora-2.1.3-r2.ebuild        2012-09-26 08:50:53.000000000 +0200
+++ -   2013-02-05 13:28:06.754073320 +0100
@@ -8,7 +8,7 @@
 DESCRIPTION="TOra - Toolkit For Oracle"
 IUSE="debug mysql oracle oci8-instant-client postgres"
@@ -45,7 +45,6 @@
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-gcc-4.7.patch #430044
        epatch "${FILESDIR}"/${P}-ext-loki.patch #383109
        sed -i \
                -e "/COPYING/ d" \
Comment 5 Michael Haubenwallner (RETIRED) gentoo-dev 2013-02-06 17:21:25 UTC
As there is no upstream tora-2.1.4 release (yet?), it doesn't feel right to create an ebuild with such a version number.

Instead, a live ebuild (version number tora-9999, checking out from upstream SVN trunk) would be more appropriate here, although live ebuilds never get any KEYWORDS at all (need to explicitly accept >**<).
Comment 6 Small_Penguin 2013-02-06 18:11:49 UTC
A live ebuild would certainly be fine, but I found the way I build it easier to do than write a new ebuild. Using an interim release "2.1.4-r4561" would be another option.

I couldn't find out which commit solved the problems - how does one search the awful svn history comfortably? a nice interface like webgit would have been helpful - , so I simply took the newest revision, as I was told by the tora devs.

To be honest: I don't know why the tora devs didn't publish a newer version with fixes for those awful problems.
Comment 7 Michael Haubenwallner (RETIRED) gentoo-dev 2013-02-06 21:20:54 UTC
Despite there's some ongoing work in tora3 branch, 've added tora-9999 live svn ebuild using current trunk.

And thank you for the updated loki patch.
Comment 8 Small_Penguin 2013-02-21 10:45:19 UTC
I've tried the new SVN ebuild now, but it does not work:

Scanning dependencies of target revisiontag
make[2]: Leaving directory `/var/tmp/portage/dev-db/tora-9999/work/tora-9999_build'
make -f CMakeFiles/revisiontag.dir/build.make CMakeFiles/revisiontag.dir/build
make[2]: Entering directory `/var/tmp/portage/dev-db/tora-9999/work/tora-9999_build'
/usr/bin/cmake -DSOURCE_DIR=/var/tmp/portage/dev-db/tora-9999/work/tora-9999 -P /var/tmp/portage/dev-db/tora-9999/work/tora-9999/cmake/modules/getsvn.cmake
-- Found Subversion: /usr/bin/svn (found version "1.7.7") 
CMake Error at /usr/share/cmake/Modules/FindSubversion.cmake:83 (message):
  Command "/usr/bin/svn info
  /var/tmp/portage/dev-db/tora-9999/work/tora-9999" failed with output:

  svn: E155007: '/var/tmp/portage/dev-db/tora-9999/work/tora-9999' is not a
  working copy

Call Stack (most recent call first):
  /var/tmp/portage/dev-db/tora-9999/work/tora-9999/cmake/modules/getsvn.cmake:8 (Subversion_WC_INFO)

make[2]: *** [revisiontag] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-db/tora-9999/work/tora-9999_build'
make[1]: *** [CMakeFiles/revisiontag.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/dev-db/tora-9999/work/tora-9999_build'
make: *** [all] Error 2
emake failed
 * ERROR: dev-db/tora-9999 failed (compile phase):
 *   (no error message)
 * Call stack:
 *, line   93:  Called src_compile
 *   environment, line 2908:  Called cmake-utils_src_compile
 *   environment, line  820:  Called _execute_optionaly 'src_compile'
 *   environment, line  328:  Called enable_cmake-utils_src_compile
 *   environment, line 1073:  Called cmake-utils_src_make
 *   environment, line  835:  Called emake_src_make
 *   environment, line 1041:  Called die
 * The specific snippet of code:
 *           emake VERBOSE=1 "$@" || die;
 * If you need support, post the output of `emerge --info '=dev-db/tora-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-db/tora-9999'`.
 * The complete build log is located at '/var/log/portage/dev-db:tora-9999:20130221-104023.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-db/tora-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/tora-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-db/tora-9999/work/tora-9999_build'
 * S: '/var/tmp/portage/dev-db/tora-9999/work/tora-9999'
Comment 9 Michael Haubenwallner (RETIRED) gentoo-dev 2013-03-08 16:43:14 UTC
Copying (cp -a) instead of symlinking (ln -s) the .svn subdirectory from ESVN_WC_PATH into sourcedir should work better.
Comment 10 Small_Penguin 2013-04-10 16:22:46 UTC
Thanks, the live ebuild works fine now.