Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 454934

Summary: games-rpg/grimrock-20121222 segfault loading dungeon editor with USE=system-libs
Product: Gentoo Linux Reporter: David Flogeras <dflogeras2>
Component: [OLD] GamesAssignee: Julian Ospald <hasufell>
Severity: normal CC: games, mva
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info as requested

Description David Flogeras 2013-02-01 02:29:33 UTC
Running amd64, when I click on dungeon editor in the main menu it segfaults.  Game itself seems to play fine (have logged a few hours without mishap)

Reproducible: Always
Comment 1 Julian Ospald 2013-02-01 11:33:07 UTC
is system-libs useflag enabled?

backtrace? stderr?
Comment 2 David Flogeras 2013-02-01 12:15:43 UTC
system-libs is on.  When I just tried -system-libs, the dungeon editor loaded.

I assumed there is not debug symbols in the bin blob. If I run 'LD_LIBRARY_PATH=/opt/grimrock/lib' cgdb /opt/grimrock/Grimrock.bin.x86_64:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffc6977bad in ?? ()

Not to useful :(

Nothing out of stderr. Just a bunch of stuff like:

 Compiling shader shaders/gl/PostProcess.vsh
 Compiling shader assets/shaders/gl/dream.fsh

from when the game loads, then Segmentation fault when it crashes.
Comment 3 Julian Ospald 2013-02-01 17:58:43 UTC
I cannot reproduce that, so disable system-libs and try removing the libs in /opt/grimrock/lib one by one to see which library is causing this
Comment 4 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2013-02-03 11:33:39 UTC
Cannot reproduce bug too.

mva@note ~ % ldd /opt/grimrock/Grimrock.bin.x86_64 | grep opt => /opt/grimrock/lib64/ (0x00007fc42f238000)

[so, I think, it is equovalent to USE=system-libs in tree's version of ebuild.]
Comment 5 David Flogeras 2013-02-04 23:21:04 UTC
(In reply to comment #3)
> I cannot reproduce that, so disable system-libs and try removing the libs in
> /opt/grimrock/lib one by one to see which library is causing this is the trigger.

My system openal is currently:
[ebuild   R    ] media-libs/openal-1.15.1  USE="alsa sse -alstream (-coreaudio) -debug (-neon) -oss -portaudio -pulseaudio"

Maybe I need some other use flag?  I ran grimrock in strace and made it crash but nothing useful presented itself.
Comment 6 David Flogeras 2013-02-04 23:22:06 UTC
By the way, even when I can get the dungeon editor to work, I cannot seem to do anything with it.  I cannot draw walls by following the on-screen instructions (LMB to draw). Can you folks?  Or maybe it has something to do with my system otherwise.
Comment 7 Julian Ospald 2013-02-04 23:40:14 UTC
still can't reproduce, have the same useflags for openal as you do

and note that the dungeoneditor is beta, maybe report such bugs upstream (if you do that, you should however make a local installation of grimrock without this ebuild)

also attach your emerge --info
Comment 8 Julian Ospald 2013-02-04 23:42:36 UTC
also, you have to create a new project in the DE before you can do anything
Comment 9 David Flogeras 2013-02-05 01:35:42 UTC
Created attachment 337964 [details]
emerge --info as requested
Comment 10 David Flogeras 2013-02-05 01:39:36 UTC
re: create new project in DE: the way they made the menu in a separate  X window is weird, and if you move the editor window, the menu gets hidden behind it (and was why I couldn't figure it out before).  If I move the window containing the menu, I can reveal the menu again.
Comment 11 Julian Ospald 2013-11-24 13:43:53 UTC
is this still happening?
Comment 12 David Flogeras 2013-11-24 23:00:46 UTC
(In reply to Julian Ospald (hasufell) from comment #11)
> is this still happening?

Seems not to be using games-rpg/grimrock-20130515 and -bundled-libs (which I assume is equivalent to +system-libs before)

Curiously, openal (seemingly the trigger from before) is still at the same version 1.15.1 so maybe was a red herring.  Oh well, close it and someone can reopen if required.