Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 45465

Summary: emerge mythtv does not work fails on BREG
Product: Gentoo Linux Reporter: Jacob Sheck <shec0002>
Component: New packagesAssignee: Television related Applications in Gentoo's Portage <media-tv>
Status: VERIFIED FIXED    
Severity: normal    
Priority: High    
Version: 2004.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: output from emerge mythfrontend

Description Jacob Sheck 2004-03-22 20:32:35 UTC
When I "emerge mythtv" it fails with the error

msmpeg4.c: In function `msmpeg4_pred_dc':
msmpeg4.c:734: error: can't find a register in class `BREG' while reloading `asm'
make[2]: *** [msmpeg4.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/mythfrontend-0.13/work/mythtv-0.13/libs/libavcodec'
make[1]: *** [sub-libavcodec] Error 2
make[1]: Leaving directory `/var/tmp/portage/mythfrontend-0.13/work/mythtv-0.13/libs'
make: *** [sub-libs] Error 2


I have tried chaing my /etc/make.conf settings includeing setting the c and cxx flags to null.  Ill attach a log of what was built.  I am using the 2.6 kernel now, and this happend with the 2.4 kernel as well.
Comment 1 Jacob Sheck 2004-03-22 20:34:39 UTC
Created attachment 27826 [details]
output from emerge mythfrontend

This is the output from mythtfrontend.	Both emerge mythtv, and emerge
mythfrontend fail in the same way.  I can access this machine at almost any
time of day, any response should be responded to asap.
Comment 2 Seemant Kulleen (RETIRED) gentoo-dev 2004-03-22 21:15:34 UTC
change your -mcpu=i686 to -march=i686 and try again, please.

Also, if you have -fPIC in your CFLAGS in make.conf, delete that bit
Comment 3 Jacob Sheck 2004-03-22 21:37:31 UTC
CFLAGS="-march=i686 -mcpu=i686"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=i686 -mcpu=i686"

msmpeg4.c: In function `msmpeg4_pred_dc':
msmpeg4.c:734: error: can't find a register in class `BREG' while reloading `asm'
make[2]: *** [msmpeg4.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/mythtv-0.13-r1/work/mythtv-0.13/libs/libavcodec'
make[1]: *** [sub-libavcodec] Error 2
make[1]: Leaving directory `/var/tmp/portage/mythtv-0.13-r1/work/mythtv-0.13/libs'
make: *** [sub-libs] Error 2
 
!!! ERROR: media-tv/mythtv-0.13-r1 failed.
!!! Function src_compile, Line 94, Exitcode 2
!!! compile problem

CFLAGS="-march=i686 -mcpu=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=i686 -mcpu=i686 -pipe"
                                                                                
msmpeg4.c: In function `msmpeg4_pred_dc':
msmpeg4.c:734: error: can't find a register in class `BREG' while reloading `asm'
make[2]: *** [msmpeg4.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/mythfrontend-0.13/work/mythtv-0.13/libs/libavcodec'
make[1]: *** [sub-libavcodec] Error 2
make[1]: Leaving directory `/var/tmp/portage/mythfrontend-0.13/work/mythtv-0.13/libs'
make: *** [sub-libs] Error 2
                                                                                
 !!! ERROR: media-tv/mythfrontend-0.13 failed.
 !!! Function src_compile, Line 85, Exitcode 2
 !!! compile problem
                                                                                
                                                                                
                                                                                
                                                                                
CFLAGS="-march=pentium4 -mcpu=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=pentium4 -mcpu=pentium4 -pipe"
                                                                                
msmpeg4.o msmpeg4.c
 msmpeg4.c: In function `msmpeg4_pred_dc':
 msmpeg4.c:734: error: can't find a register in class `BREG' while reloading `asm'
 make[2]: *** [msmpeg4.o] Error 1
 make[2]: Leaving directory `/var/tmp/portage/mythtv-0.13-r1/work/mythtv-0.13/libs/libavcodec'
 make[1]: *** [sub-libavcodec] Error 2
 make[1]: Leaving directory `/var/tmp/portage/mythtv-0.13-r1/work/mythtv-0.13/libs'
 make: *** [sub-libs] Error 2
                                                                                
  !!! ERROR: media-tv/mythtv-0.13-r1 failed.
  !!! Function src_compile, Line 94, Exitcode 2
  !!! compile problem
Comment 4 Jacob Sheck 2004-04-14 15:04:53 UTC
I unmereged gcc-harden, and now every thing compiles!
Comment 5 Jacob Sheck 2004-04-14 15:07:08 UTC
If anyone would like more information just send me a message, and I can tell you more, but for now Ill close this defect.