Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 454196

Summary: sys-apps/groff-1.22.1 installs broken symbolic link - /usr/share/doc/groff-1.22.1/pdf/mom-pdf.pdf: broken symbolic link to `/usr/share/doc/groff-1.22.1/examples/mom/mom-pdf.pdf'
Product: Gentoo Linux Reporter: Francesco Turco <mail>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal CC: mmokrejs
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=516732
Whiteboard:
Package list:
Runtime testing required: ---

Description Francesco Turco 2013-01-26 17:36:50 UTC
If I run equery check groff, all files pass the test except one:

!!! /usr/share/doc/groff-1.22.1/pdf/mom-pdf.pdf does not exist
* Checking sys-apps/groff-1.22.1 ...
   687 out of 688 files passed

If I run file /usr/share/doc/groff-1.22.1/pdf/mom-pdf.pdf, I get the following result:

/usr/share/doc/groff-1.22.1/pdf/mom-pdf.pdf: broken symbolic link to `/usr/share/doc/groff-1.22.1/examples/mom/mom-pdf.pdf'

Reproducible: Always
Comment 1 Tim Harder gentoo-dev 2013-03-09 05:13:32 UTC
This should be fixed if you re-emerge groff.
Comment 2 Tim Harder gentoo-dev 2013-03-09 05:45:11 UTC
Actually this is fixed in 1.22.2.
Comment 3 Francesco Turco 2016-12-07 14:09:08 UTC
I now have groff-1.22.3 but the /usr/share/doc/groff-1.22.3/pdf/mom-pdf.pdf is still broken because /usr/share/doc/groff-1.22.3/examples/mom/mom-pdf.pdf doesn't exist on my system.

$ equery check groff
!!! /usr/share/doc/groff-1.22.3/pdf/mom-pdf.pdf does not exist
* Checking sys-apps/groff-1.22.3 ...
   708 out of 709 files passed
Comment 4 Francesco Turco 2016-12-07 14:10:27 UTC
Please also see bug #586578
Comment 5 SpanKY gentoo-dev 2016-12-07 16:36:19 UTC
*** Bug 586578 has been marked as a duplicate of this bug. ***
Comment 6 Martin Mokrejš 2016-12-07 17:25:49 UTC
I just re-emerged groff-1.22.3 and I also get:

# equery check groff
* Checking sys-apps/groff-1.22.3 ...
!!! /usr/share/doc/groff-1.22.3/pdf/mom-pdf.pdf does not exist
   783 out of 784 files passed

#

Checking the ebuilds ...

# diff -u -w /usr/portage/sys-apps/groff/groff-1.22.2.ebuild /usr/portage/sys-apps/groff/groff-1.22.3.ebuild
--- /usr/portage/sys-apps/groff/groff-1.22.2.ebuild     2016-06-24 23:28:45.000000000 +0200
+++ /usr/portage/sys-apps/groff/groff-1.22.3.ebuild     2016-01-12 19:04:03.000000000 +0100
[cut]
@@ -83,8 +74,5 @@
        dosym eqn /usr/bin/geqn
        dosym tbl /usr/bin/gtbl
 
-       if ! use examples ; then
-               rm -rf "${ED}"/usr/share/doc/${PF}/examples
-               rm -f "${ED}"/usr/share/doc/${PF}/pdf/mom-pdf.pdf
-       fi
+       use examples || rm -rf "${ED}"/usr/share/doc/${PF}/examples
 }
# emerge -pv groff

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/groff-1.22.3::gentoo  USE="X -examples" 0 KiB


# equery files sys-apps/groff |  grep \.pdf
/usr/bin/gropdf
/usr/bin/pdfmom
/usr/bin/pdfroff
/usr/bin/roff2pdf
/usr/share/doc/groff-1.22.3/pdf
/usr/share/doc/groff-1.22.3/pdf/mom-pdf.pdf
/usr/share/doc/groff-1.22.3/pdf/pdfmark.pdf
...
/usr/share/groff/1.22.3/tmac/pdf.tmac
/usr/share/groff/1.22.3/tmac/pdfmark.tmac
/usr/share/groff/1.22.3/tmac/spdf.tmac
/usr/share/man/man1/gropdf.1.bz2
/usr/share/man/man1/pdfmom.1.bz2
/usr/share/man/man1/pdfroff.1.bz2
/usr/share/man/man1/roff2pdf.1.bz2
#
Comment 7 SpanKY gentoo-dev 2016-12-07 18:42:23 UTC
this was fixed for 1.22.2+, but then undone via bug 516732
Comment 8 SpanKY gentoo-dev 2016-12-07 18:51:52 UTC
should be addressed for real now:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8ea21c463a5b0bfbe7303361809e76735d86b03b