Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 452654

Summary: media-tv/nxtvepg-2.8.1 with tcl-8.6.0-r1: /usr/lib/tcl8.5 is not a valid Tcl/Tk library directory
Product: Gentoo Linux Reporter: Juergen Rose <rose>
Component: Current packagesAssignee: Tiziano Müller <dev-zero>
Status: RESOLVED WONTFIX    
Severity: normal CC: kripton, media-tv, treecleaner
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: Pending removal: 2015-04-19
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 451368    
Attachments: /var/tmp/portage/media-tv/nxtvepg-2.8.1/temp/build.log

Description Juergen Rose 2013-01-17 11:06:55 UTC
'emerge nxtvepg' fails with:
...
x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -Wall -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wno-pointer-sign -I. -I/usr/X11R6/include -Ibuild-x86_64 -DX11_APP_DEFAULTS=\"/etc/X11/app-defaults/Nxtvepg\" -DTK_LIBRARY_PATH=\"/usr/lib/tk8.5\" -DTCL_LIBRARY_PATH=\"/usr/lib/tcl8.5\" -DUSE_THREADS -DUSE_UTF8 -DXMLTV_OUTPUT_UTF8 -DUSE_XMLTV_IMPORT -DXMLTV_CNI_MAP_PATH=\"/usr/share/nxtvepg\" -DUSE_TTX_GRABBER -DTTX_GRAB_SCRIPT_PATH=\"/usr/share/nxtvepg\" -DUSE_DAEMON -DEPG_DB_ENV=\"HOME\" -DEPG_DB_DIR=\".nxtvdb\" -Wp,-MMD,build-x86_64/epgui/epgmain.o.dep.tmp -c -o build-x86_64/epgui/epgmain.o epgui/epgmain.c
epgui/epgmain.c: In function ‘EpgMain_StartDaemon’:
epgui/epgmain.c:1123:18: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
/usr/lib/tcl8.5 is not a valid Tcl/Tk library directory
Check the definitions of TCL_LIBRARY_PATH and TK_LIBRARY_PATH
make: *** [/usr/lib/tcl8.5/tclIndex] Error 1


There are still some environmental variables belonging to old tcl versions:
root@lynx:/root(29)# grep TCL /etc/env.d/*
/etc/env.d/50opencascade:TCLHOME=/usr/bin
/etc/env.d/50opencascade:TCLLIBPATH=/usr/lib64
/etc/env.d/50opencascade:ITCL_LIBRARY=/usr/lib64/itcl3.4
/etc/env.d/50opencascade:TCL_LIBRARY=/usr/lib64/tcl8.5



Even after deleting sci-libs/opencascade-6.5 it fails with the same error:
x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -Wall -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wno-pointer-sign -I. -I/usr/X11R6/include -Ibuild-x86_64 -DX11_APP_DEFAULTS=\"/etc/X11/app-defaults/Nxtvepg\" -DTK_LIBRARY_PATH=\"/usr/lib/tk8.5\" -DTCL_LIBRARY_PATH=\"/usr/lib/tcl8.5\" -DUSE_THREADS -DUSE_UTF8 -DXMLTV_OUTPUT_UTF8 -DUSE_XMLTV_IMPORT -DXMLTV_CNI_MAP_PATH=\"/usr/share/nxtvepg\" -DUSE_TTX_GRABBER -DTTX_GRAB_SCRIPT_PATH=\"/usr/share/nxtvepg\" -DUSE_DAEMON -DEPG_DB_ENV=\"HOME\" -DEPG_DB_DIR=\".nxtvdb\" -Wp,-MMD,build-x86_64/epgui/epgmain.o.dep.tmp -c -o build-x86_64/epgui/epgmain.o epgui/epgmain.c
epgui/epgmain.c: In function ‘EpgMain_StartDaemon’:
epgui/epgmain.c:1123:18: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
/usr/lib/tcl8.5 is not a valid Tcl/Tk library directory
Check the definitions of TCL_LIBRARY_PATH and TK_LIBRARY_PATH
make: *** [/usr/lib/tcl8.5/tclIndex] Error 1

TCL_LIBRARY_PATH is not set in the environment:
root@lynx:/root(3)# env | grep TCL
CCP4I_TCLTK=/usr/bin



Reproducible: Always




root@lynx:/root(32)# emerge --info '=media-tv/nxtvepg-2.8.1'
Portage 2.1.11.42 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.7.2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.2
Timestamp of tree: Wed, 16 Jan 2013 14:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 sage-on-gentoo science dilfridge java-overlay proaudio sunrise lisp lordvan local x-cpan g-octave
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/sage-on-gentoo /var/lib/layman/science /var/lib/layman/dilfridge /var/lib/layman/java-overlay /var/lib/layman/pro-audio /var/lib/layman/sunrise /var/lib/layman/lisp /var/lib/layman/lordvan /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fts3 fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack laptop latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pae pam pango pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb userlocales utempter v4l vaapi vala vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-tv/nxtvepg-2.8.1 was built with the following:
USE="X (multilib) unicode"



root@lynx:/root(33)# emerge -pqv '=media-tv/nxtvepg-2.8.1'
[ebuild   R   ] media-tv/nxtvepg-2.8.1  USE="X unicode"
Comment 1 Jeroen Roovers gentoo-dev 2013-01-17 15:50:24 UTC
1) Please attach a complete build log to this bug report.
2) Also, did you run

env-update; source /etc/profile

after you removed those env.d files? If that solves the problem, we know that it's sci-libs/opencascade and not media-tv/nxtvepg that is at fault here.
Comment 2 Juergen Rose 2013-01-17 16:40:56 UTC
Created attachment 335924 [details]
/var/tmp/portage/media-tv/nxtvepg-2.8.1/temp/build.log
Comment 3 Juergen Rose 2013-01-17 16:43:51 UTC
(In reply to comment #1)
> 1) Please attach a complete build log to this bug report.

I just attached the file.


> 2) Also, did you run
> 
> env-update; source /etc/profile
> 
> after you removed those env.d files? If that solves the problem, we know
> that it's sci-libs/opencascade and not media-tv/nxtvepg that is at fault
> here.


I did this already after 'emerge -C opencascade' before sending my bug description. I just did it once more with the same result.
Comment 4 Tiziano Müller gentoo-dev 2013-01-18 06:33:44 UTC
Well, there is a patch used in the ebuild to set the tcl path to /usr/lib64/tcl8.5. I guess we could update it.

Although: upstream is dead (no new release since 2008) and I am not using it anymore. Therefore I'd prefer to lastrite it.
Any objections?
Comment 5 Juergen Rose 2013-01-21 10:12:41 UTC
Hi Tiziano,

which alternative to nxtvepg would you recommend?

Regards Juergen
Comment 6 Justin Lecher gentoo-dev 2015-03-12 09:27:06 UTC
(In reply to Tiziano Müller from comment #4)
> Well, there is a patch used in the ebuild to set the tcl path to
> /usr/lib64/tcl8.5. I guess we could update it.

/usr/lib64/tcl should work.

otherwise please lastrite.
Comment 7 Pacho Ramos gentoo-dev 2015-04-26 12:56:34 UTC
dropped