Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 452410

Summary: dev-vcs/subversion-1.7.7 - AutoSplit: Can't open blib/lib/SVN/Client.pm: No such file or directory
Product: Gentoo Linux Reporter: Victor Mataré <matare>
Component: [OLD] DevelopmentAssignee: Thomas Sachau <tommy>
Status: RESOLVED OBSOLETE    
Severity: normal CC: candrews, chewi, dark.knight.ita, zerochaos
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
emerge --info

Description Victor Mataré 2013-01-15 21:08:26 UTC
subversion build fails here:

cp Client.pm blib/lib/SVN/Client.pm
AutoSplit: Can't open blib/lib/SVN/Client.pm: No such file or directory
cp ../../../../../subversion/bindings/swig/perl/native/Client.pm blib/lib/SVN/Client.pm
make[2]: *** [pm_to_blib] Error 2
make[2]: *** Waiting for unfinished jobs....

I'm suspecting a race due to MAKEOPTS="--jobs=32 --load-average=32"

Will retry to see if it's consistent or random...

Reproducible: Always
Comment 1 Victor Mataré 2013-01-15 21:09:30 UTC
Created attachment 335750 [details]
build.log
Comment 2 Victor Mataré 2013-01-15 21:10:30 UTC
Created attachment 335752 [details]
emerge --info
Comment 3 Victor Mataré 2013-01-15 22:52:43 UTC
yup, just tried again and now it builds. So probably a race condition.
Comment 4 Rick Farina (Zero_Chaos) gentoo-dev 2013-08-26 18:33:54 UTC
This happens to me as well, there is a race somewhere.
Comment 5 Craig Andrews gentoo-dev 2013-09-04 01:54:28 UTC
Doing
MAKEOPTS="--jobs=1" emerge -1 =dev-vcs/subversion-1.7.13
succeeds always. So this is certainly a race condition.
Comment 6 James Le Cuirot gentoo-dev 2016-02-02 20:33:06 UTC
Believe it or not, this is still a problem.
Comment 7 Thomas Sachau gentoo-dev 2016-08-06 17:09:51 UTC
Since the 1.7 series is no longer maintained and removed, i will close this bug as obsolete.

If you have the same issue with a newer version, please open a new bug with the details.