Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 452050

Summary: gnome-base/gvfs: drop dependency on smbclient use-flag for >=net-fs/samba-4.0.0
Product: Gentoo Linux Reporter: Torsten Kurbad <torsten>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: alxchk, devurandom, thomas
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 195703    
Attachments: gvfs-1.14.2.ebuild.patch

Description Torsten Kurbad 2013-01-14 15:12:31 UTC
On route to unmasking the new major Samba release, =net-fs/samba-4.0.0, several minor issues need to be addressed.

One of them being to identify and adapt packages depending on net-fs/samba[smbclient]. This use flag has been dropped for >=net-fs/samba-4.0.0, since the libsmbclient stuff is always installed here along with the client tools.
Unfortunately, Samba 4 also installs the header files in a new location, /usr/include/samba-4.0.

See the attached patch for a quick (and dirty) solution on how to fix the =gnome-base/gvs-1.14.2 ebuild for compatibility with Samba 4.

If questions about Samba 4 on Gentoo arise, please refer to bug #195703.

Thanks,
Torsten

Reproducible: Always
Comment 1 Torsten Kurbad 2013-01-14 15:13:06 UTC
Created attachment 335622 [details, diff]
gvfs-1.14.2.ebuild.patch
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-18 22:17:40 UTC
gvfs upstream has a more elegant build system fix: http://git.gnome.org/browse/gvfs/commit/?id=82d369758beba0c62f4e7d9d77b57784b38f6f9d

I assume that our samba-4 ebuilds do install smbclient.pc?
Comment 3 Pacho Ramos gentoo-dev 2013-08-26 12:36:36 UTC
*** Bug 463398 has been marked as a duplicate of this bug. ***
Comment 4 Torsten Kurbad 2013-09-11 09:49:52 UTC
What is holding the progress here?

Now that samba 4 matures, I'd really like to see this fixed.

Best,
Torsten
Comment 5 Pacho Ramos gentoo-dev 2013-11-16 12:15:00 UTC
should be solved in 1.16.4
Comment 6 Thomas Kemmer 2017-01-13 14:49:55 UTC
Since the last remaining samba3* version has been removed from the main tree, <gnome-base/gvfs-1.30.2 (including all stable versions) can no longer be installed with USE="samba". Portage complains about not finding an ebuild that satisfies >=net-fs/samba-3.4.6[smbclient]:

emerge: there are no ebuilds built with USE flags to satisfy ">=net-fs/samba-3.4.6[smbclient]".
!!! One of the following packages is required to complete your request:
- net-fs/samba-4.2.14::gentoo (Missing IUSE: smbclient)
- net-fs/samba-4.2.11::gentoo (Missing IUSE: smbclient)
(dependency required by "gnome-base/gvfs-1.28.3-r1::gentoo[samba]" [ebuild])
(dependency required by "gvfs" [argument])

On systems with already installed gvfs[samba], this leads to samba3 not being upgraded to samba4 due to the same error.


The previous patch

samba? ( || ( >=net-fs/samba-3.4.6[smbclient] >=net-fs/samba-4[client] ) )

does not work any longer with no samba version >=3.4.6 left that still offers a smbclient USE flag. Newer gvfs ebuilds use 

samba? ( || (
	( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-4[smbclient] )
	>=net-fs/samba-4[client] ) )

instead, which seems to work fine. However, this could now be simplified further by dropping the smbclient flag completely.

See also: https://bugs.gentoo.org/show_bug.cgi?id=604030