Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 450956

Summary: dev-libs/boost USE=icu - sub-slot operator causes downgrade to dev-libs/icu-49.1.2
Product: Gentoo Linux Reporter: Dmitriy Dyomin <dmitrodem>
Component: [OLD] LibraryAssignee: C++ Team [disbanded] <cpp+disabled>
Status: RESOLVED NEEDINFO    
Severity: normal CC: fabio.coatti
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Dmitriy Dyomin 2013-01-08 23:02:22 UTC
dev-libs/boost-1.51-r5 has a icu USE flag dependency: icu? ( >=dev-libs/icu-3.6:= ), so after installation it requires icu from slot 0/0, so it tries to downgrade dev-libs/icu to 49.1.2 (instead of 50.1-r2).
Comment 1 Andreas K. Hüttel gentoo-dev 2014-03-04 22:32:54 UTC
(In reply to Dmitriy Dyomin from comment #0)
> dev-libs/boost-1.51-r5 has a icu USE flag dependency: icu? (
> >=dev-libs/icu-3.6:= ), so after installation it requires icu from slot 0/0,
> so it tries to downgrade dev-libs/icu to 49.1.2 (instead of 50.1-r2).

That makes no sense. We need the entire portage output; something else must be involved.