Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 450340

Summary: gnome-extra/hamster-applet-2.32.1 possibly has wrong RESTRICT_PYTHON_ABIS
Product: Gentoo Linux Reporter: Alexander E. Patrakov <patrakov>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED WONTFIX    
Severity: enhancement    
Priority: Low    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Alexander E. Patrakov 2013-01-05 08:20:39 UTC
[I have not actually tried to build this package]

gnome-extra/hamster-applet-2.32.1 has less restrictive RESTRICT_PYTHON_ABIS variable than dev-python/pygtk on which it depends. This can't be right.

gnome-extra/hamster-applet: RESTRICT_PYTHON_ABIS="3.*"
dev-python/pygtk: RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"

So I think that you should copy the RESTRICT_PYTHON_ABIS variable from pygtk to hamster-applet ebuild.

Reproducible: Didn't try
Comment 1 Gilles Dartiguelongue gentoo-dev 2013-01-06 22:38:36 UTC
This is mostly wontfix until we decide whether to work on gnome2 packages using python switch to python-r1 eclasses or not.

In practice, I'd like to do this as this would make this kind of discrepancies go away but on the other hand, it is a non-negligible workload to handle.
Comment 2 Pacho Ramos gentoo-dev 2013-08-29 12:53:06 UTC
I think it doesn't deserve the effort since this package will go away with Gnome3
Comment 3 Pacho Ramos gentoo-dev 2014-11-13 11:59:42 UTC
this was removed