Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 449166

Summary: app-i18n/ibus-table-1.4.99 version bump
Product: Gentoo Linux Reporter: wanglvyun
Component: Current packagesAssignee: CJK Team <cjk>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description wanglvyun 2012-12-29 12:17:29 UTC
hey guys~

I'm an ibus-table user, filing a bug the first time in my gentoo career.


After I updated gnome-light on my laptop from 3.4 to 3.6 today(12-29-2012), 
i found that the latest app-i18n/ibus-table-1.3.9 was unable to run properly, which was built upon app-i18n/ibus-1.4.99 that is a part of dependencies of gnome-light-3.6.


When I was launching ibus-setup, the error showed like this:

~ $ ibus-setup
Traceback (most recent call last):
  File "/usr/share/ibus-table/engine/main.py", line 25, in <module>
    import ibus
ImportError: No module named ibus


The problem is reproducible. Probably there's  version mismatch between ibus-1.4.99 and ibus-table-1.3.9, i think.

I've noticed that there is the latest version ibus-table-1.4.99, and it should help.

If someone kindly  bump the latest  ibus-table-1.4.99 , that would be nice!
Comment 1 wanglvyun 2012-12-29 12:19:48 UTC
Happy New Year to you all~
Comment 2 wanglvyun 2012-12-30 11:33:44 UTC
  Hello all ~

  I've worked it out!

  After testing the packages time and time again, finally i noticed that the old app-i18n/ibus-table-1.3.9 only works properly when app-i18n/ibus-1.4.99 ' s "deprecated" USE flag enabled.
 
  The "deprecated" USE flag triggers ibus-1.4.99's "--python-library" compiling option, which is OFF by default.
  
  But surprisingly, the flag isn't in the dependency tree of ibus-table-1.3.9, probably because that it's newly added for the new ibus-1.4.99 ,while not existing in the older versions. However, the brand new ibus-1.4.99 is required by gnome 3.6. 


  So tired after two-days' test... Fortunately, it has been resolved..

  That's all.
Comment 3 Dennis Schridde 2012-12-30 12:21:49 UTC
Please reopen, as the issue persists.

There is an ibus-table-1.4.99.20121112.tar.gz package available on the ibus page. Probably that version should be added to portage (in addition to fixing the useflags as wanglvyun described).
Comment 4 Yixun Lan gentoo-dev 2013-02-06 06:05:10 UTC
can you test again as we bump ibus to 1.5.1?
we can either choose "deprecated" and "gtk3 introspection"

  (app-i18n/ibus-1.5.1::gentoo, installed) pulled in by
    >=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] required by (gnome-base/gnome-shell-3.6.2-r1::gentoo, installed)

but gnome-shell pull "gtk3 introspection" in, so in this case "deprecated" won't usable
Comment 5 wanglvyun 2013-02-12 09:54:43 UTC
(In reply to comment #4)
> can you test again as we bump ibus to 1.5.1?
> we can either choose "deprecated" and "gtk3 introspection"
> 
>   (app-i18n/ibus-1.5.1::gentoo, installed) pulled in by
>     >=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] required by
> (gnome-base/gnome-shell-3.6.2-r1::gentoo, installed)
> 
> but gnome-shell pull "gtk3 introspection" in, so in this case "deprecated"
> won't usable


Thanks for your reply, but a bit confused...

Why can't we enable both "deprecated" and "gtk3 introspection" of ibus? As ibus-table only work properly with ibus "deprecated" enabled.

What i've observed is that each of them, the three USE flags, doesn't conflict with one another.

My opinion, though maybe thoughtless, is: 
   submit a tiny modification of the ibus-table ebuild, in which ibus-table depends ibus[deprecated], thus the problem should be solved.
Comment 6 Naohiro Aota gentoo-dev 2013-04-06 05:40:14 UTC
We already have ibus-1.5.1 and ibus-table-1.5.0 in the tree.
It seems this bug is no longer problem?
Comment 7 wanglvyun 2013-04-07 13:26:27 UTC
(In reply to comment #6)
> We already have ibus-1.5.1 and ibus-table-1.5.0 in the tree.
> It seems this bug is no longer problem?

yes, test completed and all have been proved to be correct