Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 448770

Summary: [gnome-overlay] app-accessibility/at-spi2-atk-9999 fails to build due to failed patch "at-spi2-atk-2.0.2-disable-teamspaces-test.patch"
Product: Gentoo Linux Reporter: Jekyll Wu <adaptee>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: patch.out

Description Jekyll Wu 2012-12-27 05:52:33 UTC
>>> Emerging (1 of 1) app-accessibility/at-spi2-atk-9999 from gnome
>>> Unpacking source...
GIT update -->
   repository:               git://git.gnome.org/at-spi2-atk
   at the commit:            8a7aa1f41ba4010ffbe1bef1e3bb602cb9e4e6f3
   branch:                   master
   storage directory:        "/mnt/personal/distfiles/egit-src/at-spi2-atk"
   checkout type:            bare repository
Cloning into '/tmp/portage/app-accessibility/at-spi2-atk-9999/work/at-spi2-atk-9999'...
done.
Branch branch-master set up to track remote branch master from origin.
Switched to a new branch 'branch-master'
>>> Unpacked to /tmp/portage/app-accessibility/at-spi2-atk-9999/work/at-spi2-atk-9999
>>> Source unpacked in /tmp/portage/app-accessibility/at-spi2-atk-9999/work
>>> Preparing source in /tmp/portage/app-accessibility/at-spi2-atk-9999/work/at-spi2-atk-9999 ...
 * Applying at-spi2-atk-2.0.2-disable-teamspaces-test.patch ...

 * Failed Patch: at-spi2-atk-2.0.2-disable-teamspaces-test.patch !
 *  ( /var/lib/layman/gnome/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.0.2-disable-teamspaces-test.patch )


Reproducible: Always
Comment 1 Jekyll Wu 2012-12-27 05:56:05 UTC
Created attachment 333436 [details]
patch.out
Comment 2 Gilles Dartiguelongue gentoo-dev 2014-04-27 22:30:36 UTC
live ebuilds is a best effort work. If you want to use them, you should be in a condition that allows you to provide patches to fix the ebuild if it ever fails.

Closing as fixed since the ebuilds have been updated a couple of time since the opening of this report but no update was provided.