Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 448314

Summary: mail-mta/exim-4.80.1: relay_from_hosts default should include the ::1 address
Product: Gentoo Linux Reporter: Juan David Ibáñez Palomar <jdavid.ibp>
Component: [OLD] ServerAssignee: Fabian Groffen <grobian>
Status: RESOLVED FIXED    
Severity: minor CC: gentoo, net-mail
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Juan David Ibáñez Palomar 2012-12-23 16:39:07 UTC
Just installed a Gentoo server with exim and mailman. Messages sent from mailman would not be delivered. This is because the ::1 address is not included in the relay_from_hosts variable.

So this bug is just about setting a sensible default for the relay_from_hosts variable in the /etc/exim/exim.conf.dist file, it should look like this:

hostlist   relay_from_hosts = 127.0.0.1 : ::::1

Reproducible: Always

Steps to Reproduce:
1. Setup exim & mailman
2. Test by creating a mailing list, it sends an email to the mailing list owner
3. 
Actual Results:  
See the exims logs, messages are rejected with the message:

H=localhost (...) [::1] F=<...> rejected RCPT <...>: relay not permitted
Comment 1 Fabian Groffen gentoo-dev 2013-03-23 18:00:08 UTC
thanks, added