Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 448104

Summary: dev-perl/PortageXS-0.02.10-r2 - test-suite fails - Cannot open file /etc/portage/make.conf at lib//PortageXS/Core.pm line 193.
Product: Gentoo Linux Reporter: Markus Oehme <bureau>
Component: [OLD] DevelopmentAssignee: Gentoo Perl team <perl>
Status: RESOLVED INVALID    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 300119    
Attachments: build log
emerge --info

Description Markus Oehme 2012-12-21 19:12:01 UTC
Created attachment 332952 [details]
build log

On my hardened ~amd64 machine PortageXS fails to run its test-suite.
Comment 1 Markus Oehme 2012-12-21 19:12:17 UTC
Created attachment 332954 [details]
emerge --info
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-12-24 00:18:29 UTC
> Cannot open file /etc/portage/make.conf at lib//PortageXS/Core.pm line 193.

1) Where is your make.conf file? (`find /etc -name 'make.conf'`)
2) Can you move it to /etc/portage/make.conf? (It's the new location)
3) How are its permissions set? (`ls -la /etc/portage/make.conf`)

The package should support both locations at the current moment, so assigned to the maintaining herd.
Comment 3 Markus Oehme 2012-12-24 09:37:14 UTC
(In reply to comment #2)
> > Cannot open file /etc/portage/make.conf at lib//PortageXS/Core.pm line 193.
> 
> 1) Where is your make.conf file? (`find /etc -name 'make.conf'`)

It was in /etc/make.conf

> 2) Can you move it to /etc/portage/make.conf? (It's the new location)

This fixed the test-suite. After the move everything merged fine.

> 3) How are its permissions set? (`ls -la /etc/portage/make.conf`)

Permissions are 644.
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-06-13 20:29:23 UTC
> This fixed the test-suite. After the move everything merged fine.

Yes, it's not a bug. Closed.