Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 447702

Summary: sys-kernel/hardened-sources-3.7.0 fails to crosscompile for Ski-Simulator: include/linux/gfp.h:295:2: error: implicit declaration of function ‘NODE_DATA’ (and others)
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: [OLD] Core systemAssignee: The Gentoo Linux Hardened Kernel Team (OBSOLETE) <hardened-kernel+disabled>
Status: RESOLVED WORKSFORME    
Severity: normal CC: hardened, kernel
Priority: Normal    
Version: unspecified   
Hardware: IA64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: hardened-sources-3.7.0.ski.config

Description Dennis Schridde 2012-12-18 11:29:28 UTC
$ make ARCH=ia64 -j3
  GEN     /home/dschridde/Projects/kernel/build-3.7.0-hardened/Makefile
scripts/kconfig/conf --silentoldconfig Kconfig
warning: (IA64) selects ARCH_SUPPORTS_MSI which has unmet direct dependencies (!IA64_HP_SIM)
#
# configuration written to .config
#
warning: (IA64) selects ARCH_SUPPORTS_MSI which has unmet direct dependencies (!IA64_HP_SIM)
make[3]: `include/generated/nr-irqs.h' is up to date.
  GEN     /home/dschridde/Projects/kernel/build-3.7.0-hardened/Makefile
  CHK     include/generated/uapi/linux/version.h
  Using /usr/src/linux-3.7.0-hardened as source for kernel
  CHK     include/generated/utsrelease.h
  CC      kernel/bounds.s
  GEN     include/generated/bounds.h
  CC      arch/ia64/kernel/asm-offsets.s
In file included from /usr/src/linux-3.7.0-hardened/include/linux/irq.h:20:0,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/include/asm/hardirq.h:18,
                 from /usr/src/linux-3.7.0-hardened/include/linux/hardirq.h:7,
                 from /usr/src/linux-3.7.0-hardened/include/linux/interrupt.h:12,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/include/asm/mca.h:16,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/kernel/asm-offsets.c:17:
/usr/src/linux-3.7.0-hardened/include/linux/gfp.h: In function ‘node_zonelist’:
/usr/src/linux-3.7.0-hardened/include/linux/gfp.h:295:2: error: implicit declaration of function ‘NODE_DATA’ [-Werror=implicit-function-declaration]
/usr/src/linux-3.7.0-hardened/include/linux/gfp.h:295:23: error: invalid type argument of ‘->’ (have ‘int’)
In file included from /usr/src/linux-3.7.0-hardened/arch/ia64/include/asm/uaccess.h:39:0,
                 from /usr/src/linux-3.7.0-hardened/include/linux/poll.h:11,
                 from /usr/src/linux-3.7.0-hardened/include/linux/rtc.h:31,
                 from /usr/src/linux-3.7.0-hardened/include/linux/efi.h:19,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/include/asm/sal.h:40,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/include/asm/mca.h:20,
                 from /usr/src/linux-3.7.0-hardened/arch/ia64/kernel/asm-offsets.c:17:
/usr/src/linux-3.7.0-hardened/include/linux/mm.h: In function ‘page_zone’:
/usr/src/linux-3.7.0-hardened/include/linux/mm.h:703:38: error: invalid type argument of ‘->’ (have ‘int’)
cc1: some warnings being treated as errors
make[3]: *** [arch/ia64/kernel/asm-offsets.s] Error 1

Reproducible: Always




Portage 2.2.0_alpha149 (default/linux/amd64/10.0/desktop/kde, gcc-4.7.2, glibc-2
.16.0, 3.7.0-gentoo x86_64)
=================================================================
System uname: Linux-3.7.0-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor
_5000+-with-gentoo-2.2
Timestamp of tree: Tue, 18 Dec 2012 09:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo systemd ambro-cross local enlightenment kde sunrise g-ctan
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share
/openvpn/easy-rsa /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2
.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/neatx/home"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /
etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/san
dbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/te
xmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check n --with-bdeps y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg compressdebug config-protect-if
-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch prese
rve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs
 unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfile
s.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress 
--force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/
distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/ambro-cross /var/cache/
portage/local /var/cache/portage/overlays/enlightenment /var/cache/portage/overl
ays/kde /var/cache/portage/overlays/sunrise /var/lib/g-ctan"
[...]
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAG
E_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Dennis Schridde 2012-12-18 11:30:12 UTC
Created attachment 332628 [details]
hardened-sources-3.7.0.ski.config
Comment 2 Anthony Basile gentoo-dev 2012-12-18 22:00:37 UTC
Dennis, I'm not sure what to do with this one since I'm totally unfamiliar with Ski-Simulator and ia64.  Can you narrow it down to whether its a hardened issue or its there in vanilla as well?
Comment 3 Dennis Schridde 2012-12-19 09:10:48 UTC
(In reply to comment #2)
> Dennis, I'm not sure what to do with this one since I'm totally unfamiliar
> with Ski-Simulator and ia64.
Ski-Simulator is app-emulation/ski — to my knowledge the only ia64 emulator out there.

> Can you narrow it down to whether its a hardened issue or its there in vanilla
> as well?
I will have a look.
Comment 4 Anthony Basile gentoo-dev 2013-09-27 11:05:16 UTC
(In reply to Dennis Schridde from comment #3)
> (In reply to comment #2)
> > Dennis, I'm not sure what to do with this one since I'm totally unfamiliar
> > with Ski-Simulator and ia64.
> Ski-Simulator is app-emulation/ski — to my knowledge the only ia64 emulator
> out there.
> 
> > Can you narrow it down to whether its a hardened issue or its there in vanilla
> > as well?
> I will have a look.

Any news on this?
Comment 5 Dennis Schridde 2013-10-06 18:22:35 UTC
(In reply to Anthony Basile from comment #4)

> Any news on this?

3.11.4 compiles fine.

$ make ARCH=ia64 CROSS_COMPILE=ia64-unknown-linux-gnu- O=$PWD -C /usr/src/linux-3.11.4-gentoo sim_defconfig
$ make ARCH=ia64 CROSS_COMPILE=ia64-unknown-linux-gnu- boot

It even "booted".

$ mkdir dev
$ dd if=/dev/zero of=dev/sda seek=100 bs=1M count=0
$ sudo mkfs.ext2 dev/sda
$ ski bootloader vmlinux simscsi=${PWD}/dev/sd simeth=eth0 root=/dev/sda