Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 447678

Summary: sys-apps/openrc-0.11.8 - rm: cannot remove /run/openrc: Read-only file system
Product: Gentoo Hosted Projects Reporter: Francesco Turco <mail>
Component: OpenRCAssignee: OpenRC Team <openrc>
Status: RESOLVED FIXED    
Severity: normal CC: enviouzproductionz07
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 439098    

Description Francesco Turco 2012-12-18 08:29:44 UTC
I get the following error message at boot time:

* Mounting /proc...
rm: cannot remove /run/openrc: Read-only file system

It's the very first script launched by OpenRC, but I cannot determine
which one it is, as my knowledge of init scripts is very limited.

Openrc package version is 0.11.8 (on a ~amd64 system).

This is my /etc/fstab:

/dev/sda2 none  swap defaults 0 0
/dev/sda3 /     ext4 defaults 0 1
/dev/sda4 /home ext4 defaults 0 2

The last important thing to say is that if I downgrade to openrc-0.11.6 the error vanishes.

Reproducible: Always




Portage 2.1.11.38 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.16.0, 3.7.0-gentoo x86_64)
=================================================================
System uname: Linux-3.7.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-gentoo-2.2
Timestamp of tree: Sun, 16 Dec 2012 14:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.5
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/                 http://gentoo.inode.at/ http://gentoo.lagis.at/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 2"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac gdbm gif gnome gnome-keyring gnome-online-accounts gstreamer gtk iconv ieee1394 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support readline sdl session socialweb sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis webkit x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 jeremy 2012-12-19 04:42:05 UTC
I can confirm this. Amd64 stable key worded fresh install. I've been seeing the warning since first boot.
Comment 2 duby229 2012-12-19 14:01:16 UTC
I too can confirm this bug.

Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.4.9-64 x86_64)
=================================================================
System uname: Linux-3.4.9-64-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 18 Dec 2012 03:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=amdfam10"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=amdfam10"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 100 --keep-going --complete-graph --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl alsa amd64 berkdb bindist bluray branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dvd dvdr flac fortran fuse g3dvl gdbm gpm gtk iconv jpeg mmx modules mp3 mudflap multilib ncurses nls nptl nsplugin opengl openmp pam pcre png policykit pppd python r600-llvm-compiler readline session sse sse2 ssl svg tcpd threads udev unicode vdpau vorbis wifi xorg xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 duby229 2012-12-19 14:48:43 UTC
downgrading openrc does not resolve the problem for me. However it does allow more of the rc scripts to run. Even though / is still read only it does boot to login prompt now, though I cant do anything with it because its read only.
Comment 4 jeremy 2012-12-19 16:46:57 UTC
@duby I think you may have other problems aside from this bug. at the point when this bug appears the rootfs is infact read only. The rootfs doesn't get remounted as read/write until later in the boot process. Which it does...at least on my system. If you don't ever get remounted r/w and are always stuck as read only then you have larger problems. Maybe check your fstab settings.
Comment 5 duby229 2012-12-19 16:53:35 UTC
Thank you for the info jeremy I think in my case the problem ultimately comes down to mounting /run. 

This is typed out, but this is the error message I get during boot

   * mounting /proc ...
rm: cannot remove '/run/openrc' :read only file system
   * mounting /run ...
mount: wrong fs type, bad option, bad superblock on tmpfs,
       missing codepage or helper program, or other error
       

* unable to mount tmpfs on /run
* can't continue

mkdir '/run/openrc/starting' :no such file or directory
....
....
Comment 6 duby229 2012-12-19 17:00:59 UTC
Actually please disregard that last error message that is not quite correct, that one is the error I got -before- I downgraded openrc, the one I get now is almost identical though.... As can be seen the only difference is that it does not say that it couldnt remove /run/openrc. I think it does successfully remove open /run/openrc now, but it still doesnt successfully mount /run


   * mounting /proc ...
   * mounting /run ...
mount: wrong fs type, bad option, bad superblock on tmpfs,
            missing codepage or helper program, or other error


* unable to mount tmpfs on /run
* can't continue

mkdir '/run/openrc/starting' :no such file or directory
....
....
Comment 7 jeremy 2012-12-19 17:12:10 UTC
@duby I'm gonna assume this is a fresh install or you rebuilt your kernel recently. I'm willing to be its a back kernel config. I think CONFIG_TMPFS is not set. Chroot back in from a live CD or something just as you did during install and rebuild the kernel making sure it is set. If that does t solve it then open a forum post and we will work through it from there
Comment 8 William Hubbs gentoo-dev 2012-12-19 17:50:14 UTC
(In reply to comment #0)
> I get the following error message at boot time:
> 
> * Mounting /proc...
> rm: cannot remove /run/openrc: Read-only file system


This will go away in 0.12. It is fixed in commit b44f96a. It doesn't harm your system, so there is no need for a 0.11.x release to fix it.

(In reply to comment #6)
> Actually please disregard that last error message that is not quite correct,
> that one is the error I got -before- I downgraded openrc, the one I get now
> is almost identical though.... As can be seen the only difference is that it
> does not say that it couldnt remove /run/openrc. I think it does
> successfully remove open /run/openrc now, but it still doesnt successfully
> mount /run
> 
> 
>    * mounting /proc ...
>    * mounting /run ...
> mount: wrong fs type, bad option, bad superblock on tmpfs,
>             missing codepage or helper program, or other error
> 
> 
> * unable to mount tmpfs on /run
> * can't continue
> 
> mkdir '/run/openrc/starting' :no such file or directory
> ....
> ....

Yes, this is a separate issue. it is probably as stated; you do not have CONFIG_TMPFS=y in your kernel.

Please rebuild your kernel with this setting and open a new bug if this continues.
Comment 9 Alexey Sarychev 2013-07-31 04:53:24 UTC
Workaround - manually delete obsolete symlink:

mkdir /tmp/tmpdir
sudo mount --bind / /tmp/tmpdir
sudo rm /tmp/tmpdir/run/openrc
sudo umount /tmp/tmpdir
rmdir /tmp/tmpdir

It has to be done only once, after that there will be no more annoying message at boot time.