Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 444542

Summary: dev-libs/libnl-3.2.15 - Breaks net-wireless/wpa_supplicant-1.0-r2, sys-power/powertop-2.2-r1 and more.
Product: Gentoo Linux Reporter: Tolga Dalman <tdalman>
Component: [OLD] LibraryAssignee: Netmon Herd <netmon>
Status: RESOLVED FIXED    
Severity: major CC: alexandre.guimaraes, casta, creffett, eandry, giovanni.bobbio, johannes.hirte, marduk, marek.bartosiewicz, pageexec, russell, sobhan, sudormrfhalt, theosib, tomwij, uzytkownik2, zerochaos
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info
emerge --info
gdb backtrace of powertop-2.2 with libnl-3.2.15

Description Tolga Dalman 2012-11-24 10:00:28 UTC
Created attachment 330410 [details]
emerge --info

After upgrading to dev-libs/libnl-3.15, wpa_supplicant won't start anymore and crashes instead with a segfault. Because neither reemerging both packages, nor revdep-rebuild resolved this issue, I reverted back to dev-libs/libnl-3.14 and everything is fine again.
Comment 1 Guillaume Castagnino 2012-11-24 10:40:27 UTC
hostapd is broken too with libnl-3.15. I have to revert back to libnl-3.14 to make it start again


Nov 24 11:35:12 coruscant kernel: hostapd[7985]: segfault at c ip 000002987a6f45da sp 000003fb379f92b0 error 4 in libnl-3.so.200.12.0[2987a6e8000+1d000]
Nov 24 11:35:12 coruscant kernel: grsec: From 127.0.0.6: Segmentation fault occurred at 000000000000000c in /usr/sbin/hostapd[hostapd:7985] uid/euid:0/0 gid/egid:0/0, parent /sbin/rc[start-stop-daem:7972] uid/euid:0/0 gid/egid:0/0


# emerge --info libnl
Portage 2.2.0_alpha142 (hardened/linux/amd64/no-multilib, gcc-4.6.3, glibc-2.16.0, 3.6.6-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.6.6-hardened-x86_64-Intel-R-_Atom-TM-_CPU_D510_@_1.66GHz-with-gentoo-2.2
Timestamp of tree: Sat, 24 Nov 2012 09:45:02 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.10.1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.69
sys-devel/automake:       1.12.5
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo gcpan xwing local_portage
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -mtune=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -mtune=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://dagobah.xwing.info/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/     http://mirror.ovh.net/gentoo-distfiles/ http://gentoo.tiscali.nl/"
LANG="fr_FR.utf8"
LC_ALL="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--sort-common"
LINGUAS="fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/gcpan-portage /usr/local/portage/portage /usr/local/portage/local-portage"
SYNC="rsync://dagobah.xwing.info/gentoo-portage"
USE="acl acpi amd64 bash-completion bashlogger bzip2 caps cli cracklib crypt cups cxx dri fontconfig hardened iconv idn iproute2 ipv6 ithreads jpeg justify mmx mudflap ncurses nls nptl openldap openmp pam pax_kernel pcre png pppd readline sasl session sieve sse sse2 sse3 ssl ssse3 syslog tcpd threads tiff unicode urandom vim-pager vim-syntax xattr zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi gzip headers_more limit_req limit_conn map proxy realip referer rewrite stub_status upstream_ip_hash userid" PHP_TARGETS="php5-4" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-libs/libnl-3.2.15 was built with the following:
USE="-doc -static-libs -utils"
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-24 12:31:50 UTC
I can replicate this bug as well, for both wpa_supplicant and powertop which points out the issue is most likely due to an API breakage in libnl (hostapd also mentioned in previous comment). Used gdb yesterday to figure out libnl was the issue for both packages breaking, I however didn't capture a stack trace at that point because I was in a hurry to get my internet up and running again.

If anyone else can generate a stack trace, go ahead; else I will attempt to generate one this weekend.

Bumped the severity as at least four people are experiencing this and this can be considered to be more towards a crash thus being a major issue...

Assigned to herd maintaining libnl.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-24 12:40:15 UTC
Created attachment 330422 [details]
emerge --info
Comment 4 Albert W. Hopkins 2012-11-24 14:00:55 UTC
I too had a problem generationg a stacktrace, but thought it was just me.

I recompiled both packages (libnl, wpa_suplicant) with CFLAGS="-O0 -ggdb" FEATURES="nostrip" but after that I'm not getting segfaults (yet).
Comment 5 Jeroen Roovers gentoo-dev 2012-11-24 16:22:44 UTC
Created attachment 330466 [details]
gdb backtrace of powertop-2.2 with libnl-3.2.15
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-11-24 16:41:27 UTC
Don't use -O0 if you're trying to reproduce a crash.
Comment 7 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-24 19:18:55 UTC
*** Bug 444606 has been marked as a duplicate of this bug. ***
Comment 8 Sobhan Mohammadpour gentoo-dev 2012-11-25 19:12:49 UTC
why it's not masked ?
Comment 9 Tolga Dalman 2012-11-25 22:34:35 UTC
(In reply to comment #8)
> why it's not masked ?

It is now.
Comment 10 Jeroen Roovers gentoo-dev 2012-11-26 13:43:37 UTC
(In reply to comment #8)
> why it's not masked ?

jer@gentoo.org 	2012-11-24 17:21:25 CET Keywords PMASKED
Comment 11 Thomas Graf 2012-11-26 16:52:30 UTC
I have released libnl-3.2.16 to fix this issue. Sorry for the regression, it slipped our testing.
Comment 12 Rick Farina (Zero_Chaos) gentoo-dev 2012-11-26 17:43:45 UTC
+  26 Nov 2012; Rick Farina <zerochaos@gentoo.org> +libnl-3.2.16.ebuild:
+  version bump from upstream to address bug 444542

I tested with powertop, please confirm this solves your issues if possible.
Comment 13 Jeroen Roovers gentoo-dev 2012-11-26 19:13:18 UTC
3.2.15 is gone.
Comment 14 Timothy Miller 2012-11-26 19:23:01 UTC
Well, powertop doesn't crash anymore, but it does show meaningless stuff like this:

Summary: -nan wakeups/second,  -nan GPU ops/seconds, -nan VFS ops/sec and -0.0% CPU use

No idea if that's related to this library or not.
Comment 15 Jeroen Roovers gentoo-dev 2012-11-26 19:38:10 UTC
(In reply to comment #14)
> Well, powertop doesn't crash anymore, but it does show meaningless stuff
> like this:
> 
> Summary: -nan wakeups/second,  -nan GPU ops/seconds, -nan VFS ops/sec and
> -0.0% CPU use
> 
> No idea if that's related to this library or not.

Unrelated.
Comment 16 Guillaume Castagnino 2012-11-26 19:45:18 UTC
Thanks, confirmed, hostapd is OK with 3.2.16 !
Comment 17 Sergey Popov gentoo-dev Security 2012-11-27 08:51:54 UTC
Ok, closing this as FIXED
Comment 18 Albert W. Hopkins 2012-11-27 18:15:38 UTC
(In reply to comment #17)
> Ok, closing this as FIXED

Thank you much!