Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 444394

Summary: sys-apps/dtc-1.3.0-r1 - /usr/bin/install: cannot stat 'fdtdump': No such file or directory
Product: Gentoo Linux Reporter: Anton Romanov <theli.ua>
Component: [OLD] Core systemAssignee: Luca Barbato <lu_zero>
Status: RESOLVED FIXED    
Severity: normal CC: jamie, mbt, ppc64, waebbl
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
new ebuild that renames ftdump.c to fdtdump.c

Description Anton Romanov 2012-11-23 06:58:57 UTC
Created attachment 330288 [details]
build.log

>>> Source compiled.
>>> Test phase [not enabled]: sys-apps/dtc-1.3.0-r1

>>> Install dtc-1.3.0-r1 into /var/tmp/portage/sys-apps/dtc-1.3.0-r1/image/ category sys-apps
make -j8 DESTDIR=/var/tmp/portage/sys-apps/dtc-1.3.0-r1/image/ install 
set -e; echo '	CHK version_gen.h'; mkdir -p ./; 	(echo "#define DTC_VERSION \"DTC 1.3.0\""; ) < Makefile > version_gen.h.tmp; if [ -r version_gen.h ] && cmp -s version_gen.h version_gen.h.tmp; then rm -f version_gen.h.tmp; else echo '	UPD version_gen.h'; mv -f version_gen.h.tmp version_gen.h; fi;
	CHK version_gen.h
/usr/bin/install -d /var/tmp/portage/sys-apps/dtc-1.3.0-r1/image//usr/bin
/usr/bin/install convert-dtsv0 dtc fdtdump dtdiff /var/tmp/portage/sys-apps/dtc-1.3.0-r1/image//usr/bin
/usr/bin/install: cannot stat 'fdtdump': No such file or directory
make: *** [install] Error 1
 * ERROR: sys-apps/dtc-1.3.0-r1 failed (install phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-apps/dtc-1.3.0-r1'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/dtc-1.3.0-r1'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/work/dtc-v1.3.0'
 * S: '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/work/dtc-v1.3.0'

>>> Failed to emerge sys-apps/dtc-1.3.0-r1, Log file:

>>>  '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/temp/build.log'

 * Messages for package sys-apps/dtc-1.3.0-r1:

 * ERROR: sys-apps/dtc-1.3.0-r1 failed (install phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-apps/dtc-1.3.0-r1'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/dtc-1.3.0-r1'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/work/dtc-v1.3.0'
 * S: '/var/tmp/portage/sys-apps/dtc-1.3.0-r1/work/dtc-v1.3.0'
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-23 09:46:23 UTC
Can you provide the output of `emerge --info` in a comment?
Comment 2 Mike Thompson 2012-12-01 12:45:48 UTC
I'm running into the very same issue.  Originally I hit the recent problem of a collision between this package and media-libs/freetype over /usr/bin/ftdump and unkeyworded sys-apps/dtc-1.3.0-r1 to fix it.  Now this.  Here's my emerge --info.


Portage 2.1.11.31 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo x86_64)
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-Intel-R-_Core-TM-_i5-2320_CPU_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Sat, 01 Dec 2012 01:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.6
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-local-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm PUEL AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=core2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O3 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"                                                                   
FFLAGS="-O3 -march=core2 -pipe -fomit-frame-pointer -funroll-all-loops"                             
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://mirrors.kernel.org/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                       
LANG="en_US.UTF-8"                                                                                  
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--as-needed"                          
LINGUAS="en"                                                                                        
MAKEOPTS="-j5"                                                                                      
PKGDIR="/usr/portage/packages"                                                                      
PORTAGE_CONFIGROOT="/"                                                                              
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                             
PORTAGE_TMPDIR="/var/tmp"                                                                           
PORTDIR="/usr/portage"                                                                              
PORTDIR_OVERLAY="/var/lib/local-overlay"                                                            
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cdr cjk cli consolekit cracklib crypt cups curl cxx dbus declarative doc dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gmp gnutls gpm gtk iconv icu idn ipv6 jpeg kde kipi latex lcms ldap libnotify lvm mad mmap mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qemu qt3support qt4 readline sdl semantic-desktop session slang spell sql sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis webkit wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver pdfimport wiki-publisher" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Jamie Furtner 2012-12-18 23:29:49 UTC
I'm running into this also, and from what I can tell the problem is that the patch isn't renaming the ftdump.c file to fdtdump.c and therefore fdtdump isn't built. I don't know enough about patch files to know how to fix it in there. 

I created a 1.3.0-r2 ebuild that just renamed the file in the prepare phase and it works.

I've attached the ebuild - feel free to use it or fix this properly in the patch file.

My emerge --info:
Portage 2.1.11.37 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.3-gentoo x86_64)
=================================================================
System uname: Linux-3.5.3-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Tue, 18 Dec 2012 22:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.5, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo rion bleeding-edge betagarden Local-repository
Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--oneshot --load-average=2.5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.arcticnetwork.ca/pub/gentoo/ http://gentoo.arcticnetwork.ca/source/ http://gentoo.mirrors.tera-byte.com/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/rion /var/lib/layman/bleeding-edge /var/lib/layman/betagarden /usr/local/local-portage"
SYNC="rsync://rsync5.ca.gentoo.org/gentoo-portage"
USE="X acl aio alsa amd64 apache2 bash-completion berkdb bzip2 cli cracklib crypt cups cxx dri fam fortran gdbm gif gpm iconv ipv6 jpeg kerberos ldap maildir mmx mmxext modules mp3 mudflap multilib ncurses network nls nptl offensive openmp pam pcre png pppd readline samba session sse sse2 ssl ssse3 tcpd threads tiff truetype unicode usb vim-syntax zlib" ALSA_CARDS="seq-dummy dummy virmidi mpu401 loopback usb-audio intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_ca.utf8 en.utf8 en_us.utf8 en_GB.utf8 en_gb.utf8 en_ca en en_us en_GB en_gb" LIRC_DEVICES="atiusb" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="microtek microtek2" USERLAND="GNU" VIDEO_CARDS="vesa fbdev apm vga nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 4 Jamie Furtner 2012-12-18 23:30:39 UTC
Created attachment 332694 [details]
new ebuild that renames ftdump.c to fdtdump.c
Comment 5 Bernd Waibel 2013-02-23 18:30:29 UTC
I'm running into the same issue. Although, if I understand the patch in ${FILESDIR} correctly, it is supposed to rename the file, it doesn't actually perform this action. I can confirm, the provided ebuild by Jamie Furtner in #4 be working.

My emerge info:
Portage 2.1.11.50 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.7.9-gentoo-monolithic x86_64)
=================================================================
System uname: Linux-3.7.9-gentoo-monolithic-x86_64-AMD_Athlon-tm-_7850_Dual-Core_Processor-with-gentoo-2.1
KiB Mem:     4047220 total,   1336712 free
KiB Swap:    4194300 total,   3946192 free
Timestamp of tree: Sat, 23 Feb 2013 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo local enlightenment gentoo-guis java-overlay multilib multimedia science sunrise gamerlay seden octave niftyled
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdep y --complete-graph --jobs --load-average 3"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://de-mirror.org/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/enlightenment /var/lib/layman/gentoo-guis /var/lib/layman/java-overlay /var/lib/layman/multilib-portage /var/lib/layman/multimedia /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/gamerlay /var/lib/layman/seden /var/lib/layman/octave /var/lib/layman/niftyled"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 amr ao bash-completion bluetooth branding bzip2 cairo cdda cddb cdio cdr cli consolekit cracklib crypt cryptsetup cscope cups curl cxx dbus device-mapper dga dmx dri dts dv dvd dvdr dvi emacs emboss encode exif fam ffmpeg flac fluidsynth fontconfig fortran gcrypt gd gdbm gif git glade gmp gnome gnome-keyring graphviz gstreamer gtk gtk3 http i18n iconv icu idn imagemagick inotify iodbc ipv6 jadetex java jbig jpeg jpeg2k kde kerberos lame latex lcms libffi libnotify libproxy lzma mad midi mjpeg mms mmx mmxext mng modules mono mp3 mp4 mpeg mudflap multilib musepack ncurses nls nptl offensive ogg openal opencl openexr opengl openmp opus pam pango pcre pdf pgf phonon png pnm policykit postscript ppds pstricks pulseaudio python qt3support qt4 raw readline samba sdl semantic-desktop session sndfile sound speex spell sqlite sse sse2 sse3 ssl ssse3 startup-notification subversion svg systemd systemtap t1lib taglib tcpd tga theora tiff truetype twolame udev udisks unicode upower vaapi vcd vcdx vdpau vim vlc vorbis vpx wavpack webp wmf x264 xattr xcb xine xinerama xml xmp xpm xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps crypt crypt-gpg lvm systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="multiboot pc qemu" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver pdfimport presenter-console presenter-minimizer" LINGUAS="de en en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm armeb i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev modesetting nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 6 SpanKY gentoo-dev 2014-11-17 07:38:53 UTC
dtc-1.4.0 should have fixed this issue