Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 443604

Summary: dev-dotnet/libgdiplus-2.10 - ../src/.libs/libgdiplus.so: error: undefined reference to 'atan' /// (missing -lm)
Product: Gentoo Linux Reporter: Moritz Schlarb <moschlar>
Component: [OLD] LibraryAssignee: dotnet <dotnet>
Status: RESOLVED DUPLICATE    
Severity: normal CC: moschlar
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: patch to add -lm to the linker flags

Description Moritz Schlarb 2012-11-17 11:04:10 UTC
When using the gold linker, compiling dev-dotnet/libgdiplus-2.10 fails at

Making all in tests
make[2]: Entering directory `/var/tmp/portage/dev-dotnet/libgdiplus-2.10/work/libgdiplus-2.10/tests'

with

../src/.libs/libgdiplus.so: error: undefined reference to 'atan'
../src/.libs/libgdiplus.so: error: undefined reference to 'floorf'
../src/.libs/libgdiplus.so: error: undefined reference to 'pow'

etc.


Reproducible: Always

Steps to Reproduce:
1. binutils-config --linker ld.gold
2. emerge =dev-dotnet/libgdiplus-2.10
Comment 1 Moritz Schlarb 2012-11-17 11:05:10 UTC
Created attachment 329692 [details, diff]
patch to add -lm to the linker flags

Adds -lm to the linker flags for dev-dotnet/libgdiplus-2.10 in the tests subdirectory.
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-18 22:25:43 UTC
1. Please comment with the output of `emerge --info`.
2. Please attach the full build log to your bug.

Thank you.
Comment 3 Moritz Schlarb 2012-11-19 10:30:17 UTC
(In reply to comment #2)
> 1. Please comment with the output of `emerge --info`.

Portage 2.1.11.31 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo i686)
=================================================================
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Core-TM-_Duo_CPU_L2400_@_1.66GHz-with-gentoo-2.1
Timestamp of tree: Sat, 17 Nov 2012 14:15:01 +0000
ld GNU gold (GNU Binutils 2.22) 1.11
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo sunrise moonrise local g-ctan
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=prescott -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=prescott -pipe"
GENTOO_MIRRORS="ftp://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-O2 -march=prescott -pipe -Wl,-O2"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/moonrise /usr/local/portage /var/lib/g-ctan"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb branding bzip2 cairo cdda cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd emboss encode evo exif fam ffmpeg firefox flac fontconfig fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad matroska mmx mmxext mng modules mp3 mp4 mpeg mudflap nautilus ncurses networkmanager nls nptl offensive ogg opengl openmp optimization pam pango pcre pdf png policykit ppds pppd pulseaudio python qt3support readline samba sdl session socialweb spell sqlite sse ssl startup-notification strong-optimization svg tcpd theora tiff truetype udev udisks unicode upower usb vaapi vim-syntax vorbis wxwidgets x264 x86 xa xcb xinerama xml xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64 ppc arm mips" QEMU_USER_TARGETS="i386 x86_64 ppc arm mips" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


> 2. Please attach the full build log to your bug.

Which is already gone, but since I think that the maintainer will reproduce this anyway before thinking of applying my patch (and to reproduce it should suffice to change the linker to gold), I think it's not so crucial in this case.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-01-06 21:37:53 UTC

*** This bug has been marked as a duplicate of bug 367345 ***