Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 442876

Summary: app-emulation/virtualbox-4.2.4: after upgrade some VMs do not start anymore
Product: Gentoo Linux Reporter: Juergen Rose <rose>
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED FIXED    
Severity: normal CC: bkohler, kripton, patrick, proxy-maint, swapon
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Juergen Rose 2012-11-12 14:44:20 UTC
If I start an upgraded aptosid-keres linux-3.6-5.slh.3-aptosid-amd64 (reconvery mode) in virtualbox-4.2.4 it fails with:

[  24.039107] invalid opcode: 0000 [#1] PREEMPT SMP
[  24.040026] Modules linked in: af_packet fuse ...
[  24.040026] Pid: 0, comm: swapper/0 Tainted: G   W 0 3.6-5.slh.3-aptosid-amd64 #1 innotek GmbH VirualBox/VirtualBox
...
[  24.040026] Kernel panic - not syncing: Attempted to kill the idel task!


Three days ago with virtualbox-4.2.2 it was still running.
Comment 1 Juergen Rose 2012-11-12 14:48:55 UTC
Gentoo-Live (livedvd-amd64-multilib-2012.iso) comes to:
...
  :: Scanning for fuse...fuse loaded.
  :: Scanning for e1000...
Comment 2 Juergen Rose 2012-11-12 15:06:00 UTC
Ubuntu 3.2.0-32 (recovery mode) fails with:
...
[    2.492303]  RSP <ffffffff81c01eb8>
[    2.492303] ---[ end trace d677a5a26c0f0d66 ]---
[    2.492303] Kernel panic - not syncing: Attempted to kill the idle task!
[    2.492303] Pid: 0, comm: swapper/0 Tainted: T      D W    3.2.0-32-generic #51-Ubuntu
Comment 3 Juergen Rose 2012-11-12 15:07:10 UTC
Win-XP works.
Comment 4 Juergen Rose 2012-11-13 19:01:30 UTC
After installing virtualbox-4.2.4-r1 I could start Ubuntu and could add VBoxGuestAdditions and even succesfully reboot. But beginning with the second reboot all further attempt to boot Ubuntu failed again with Kernel panic. 

Aptosid-keres fails immediately invalid opcode: 0000 and Kernel panic,
WinXp bootes like a charm.

At a second computer I have no problem with virtualbox-4.2.4 and the same VMs.
One difference is that virtualbox-4.2.4 at the affected system was compiled with debug flags:

CFLAGS="-march=native -O2 -ggdb"
FEATURES="splitdebug noclean nostrip"

Could this be the reasons for the problems?
Comment 5 Juergen Rose 2012-11-21 14:35:09 UTC
It seems me, that after reboot of the host (Linux leopard 3.6.6-gentoo #3 SMP Tue Nov 13 18:03:11 CET 2012 x86_64 Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz GenuineIntel GNU/Linux), I can't start my linux VMx only one or two time. Rebooting seems to be less critical. But if I shutdown and start again a linux VM it certainly crashes during bootin. Maybe the crashes are anyway connected with swapping, aptosid crashes at least with:

[     7.027622] invalid upcode: 0000 [#1] PREEMT SMP
[     7.027765] Modules linked in: sg sr_mod cdrom sd_mod crc_t10dif ata_generic pata_acpi ohci_hcd ehci_hci libahci ata_piix e1000 libata scsi_mod
[     7.027983] CPU 0
[     7.027997] Pid: 0, comm: swapper/0 Tainted: G        W    3.6-7,slh.1-aptosid-amd64 # innotek GmbH VirtualBox/VirtualBox


ubuntu crashes with:

[     8.242235] Kernel panic - not syncing: Attempted to kill the idle task!
[     8.242235] Pid: 0 comm: swapper/0 Tainted: T       D W    3.2.0-33-generic #52-Ubuntu


Top at the host said:

KiB Mem:   8124004 total,  3833296 used,  4290708 free,   125940 buffers
KiB Swap: 33554424 total,    30948 used, 33523476 free,  1748380 cached

i.e. there is not very much swapping at the host side. The VMs I have imported from an other host. At the other host (Linux moose 3.6.6-gentoo #1 SMP Tue Nov 6 17:57:14 CET 2012 x86_64 Intel(R) Core(TM)2 Quad CPU Q9650 @ 3.00GHz GenuineIntel GNU/Linux) I don't have any problems with theese linux VMs.

A Win-XP VM I can start anytimes without problems. For each linux VM 2048 MB main memory is reserved. Stopping and restarting of VirtualBox does not change anything only rebooting of the host helps for a short time.

Any idea?
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2012-12-23 09:03:32 UTC
Is this still a problem with virtualbox-4.2.6?
Comment 7 Juergen Rose 2013-01-02 19:55:58 UTC
It seems me that the issue disappeared with virtualbox-4.2.6. Anybody knows why?
Comment 8 Ben Kohler gentoo-dev 2013-10-02 14:56:41 UTC
Seems like a bug isolated to a tree-cleaned version, not much to do here since all in-tree versions work and we can't reproduce it anymore.  Please re-open if you feel this still needs attention.