Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 441036

Summary: dev-util/insight-6.8.1 - glibc-2.16.0 causes linux-nat.h:63:18: error: field ‘siginfo’ has incomplete type
Product: Gentoo Linux Reporter: David J Cozatt <djcozatt>
Component: Current packagesAssignee: Development Tools Team <dev-tools>
Status: RESOLVED FIXED    
Severity: normal CC: proteuss, tomwij, zeekec
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge info insight
build log
Backport of the other patch sorta

Description David J Cozatt 2012-11-03 03:17:01 UTC
This is an emerge -e world after pulling in the bumps from last night. 

ERROR: dev-util/insight-6.8.1 failed (compile phase):                         │
│  emake failed 




Reproducible: Always
Comment 1 David J Cozatt 2012-11-03 03:19:13 UTC
Created attachment 328166 [details]
emerge info insight
Comment 2 David J Cozatt 2012-11-03 03:20:25 UTC
Created attachment 328168 [details]
build log
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-03 16:20:33 UTC
Thanks for providing the info and build log, I have updated the title and assigned the bug to the maintainers of dev-util/insight.
Comment 4 Yixun Lan gentoo-dev 2012-11-05 09:35:48 UTC
(In reply to comment #3)
> Thanks for providing the info and build log, I have updated the title and
> assigned the bug to the maintainers of dev-util/insight.

confirmed here, same problem, I've upgraded to glibc-2.16.0,but it compiled fine with glibc-2.15
Comment 6 Greg Turner 2012-12-09 09:32:55 UTC
Created attachment 331864 [details, diff]
Backport of the other patch sorta

Confirmed... this did it for my 6.8.1 as of the last time I rsynced, probably a few days ago.
Comment 7 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2013-02-04 07:14:27 UTC
*** Bug 451692 has been marked as a duplicate of this bug. ***
Comment 8 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2013-02-04 07:16:40 UTC
+  04 Feb 2013; Kacper Kowalik <xarthisius@gentoo.org> +insight-6.8.1-r1.ebuild,
+  -files/insight-6.6-DESTDIR.patch, -files/insight-6.6-burn-paths.patch,
+  -files/tkImgGIF.patch, -insight-6.7.1-r1.ebuild:
+  Fix building with tcl-6.0 and glibc-2.16. Fixes #452820, #441036. Thanks to
+  Helmut Jarausch <jarausch@igpm.rwth-aachen.de> and Ian Abbott <ian@abbott.org>
+  for their patches. Drop old