Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 440794

Summary: media-gfx/digikam 2.9.0 - digikam (core): Failed to detect camera with GPhoto2 from Solid (canon ixus 300 HS)
Product: Gentoo Linux Reporter: Stephan Karacson <stkaopen>
Component: Current packagesAssignee: Andreas K. Hüttel <dilfridge>
Status: RESOLVED CANTFIX    
Severity: normal CC: creffett, kde
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=307839
Whiteboard:
Package list:
Runtime testing required: ---

Description Stephan Karacson 2012-11-01 17:24:01 UTC
Digikam 2.9.0 fails to import photos from my camera

workaround: mask 2.9.0 and downgrade to 2.6.0.

Reproducible: Always

Steps to Reproduce:
1. connect camera
2. select import camera
Actual Results:  
import-window doesn't show up

digikam(27833)/digikam (core): Failed to get information for the listed camera 
digikam(27833)/digikam (core): Failed to detect camera with GPhoto2 from Solid information

Expected Results:  
import-window does show up

tested camera: canon ixus 300 HS
Comment 1 Jeroen Roovers gentoo-dev 2012-11-01 17:29:33 UTC
1) Please post your `emerge --info' output in a comment.
Comment 2 Stephan Karacson 2012-11-01 19:05:26 UTC
bug seen too on https://bugs.kde.org/show_bug.cgi?id=307839
At least we have to keep 2.6.0 if it's upstream.

Sorry, my emerge --info:
$ emerge --info
Portage 2.1.11.9 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.4.9-gentoo x86_64)
=================================================================
System uname: Linux-3.4.9-gentoo-x86_64-Intel-R-_Core-TM-_i7-2720QM_CPU_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Thu, 01 Nov 2012 13:15:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA skype-4.0.0.7-copyright ut2003 PUEL AdobeFlash-10.3 googleearth"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mno-avx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mno-avx"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ "
LANG="de_AT.UTF-8"
LC_ALL="de_AT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aacs acei acl acpi acpi4linux addressbook alsa amd64 apm apng audiofile bidi binfilter bluetooth bluray bzip2 c c++ cdaudio cdda cddb cdinstall cdparanoia cdr cdrom chroot cjk clamav cli codecs consolekit cracklib css cups cvs cxx dbus declarative device-mapper dhcp dhcpcd dri dvd dvdnav dvdread emul-linux-x86 encode ethereal exif extras ffmpeg flac flash fontconfig foomaticdb fortran ftp g3dvl gallium gcj gdbm german gif gnutls gphoto2 gpm gudev h323 hal hwdb iconv imap imlib irmc java javascript joystick jpeg jpeg2k kde kdepim lame langpacks libwww live lm_sensors lua lzma mad matroska md5sum midi mikmod minizip mjpeg mmx mmx2 mmxext mng mod modules mp2 mp3 mp4 mp4live mpeg mpeg2 mpeg4 mudflap multilib multimedia music ncurses net network networkmanager nls nptl nvidia obex ogg oggvorbis opengl openmp oss pam pcre pdf phonon plasma pmu png pnm pnp policykit postscript pppd qt4 quicktime readline reports rtc rtsp scanner semantic-desktop session smime smp sound sounds sqlite sse sse2 ssl stream svg svgz sysfs tcpd templates theora threads tiff timidity transcode truetype udisks unicode usb utf8 vcd vdpau videos vlc vlm vorbis wav webkit webm wma wmf wmp x264 xcb xml xpm xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="synaptics mouse evdev keyboard joystick void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Stephan Karacson 2012-11-25 13:29:55 UTC
Why did you remove digikam 2.6.0 when you know that 2.9.0 is broken?
At least for me as a canon-user 2.9.0 is unusable.
Upgrade of kde makes a reemerge of 2.6.0 necessary. After removal of 2.6.0 out of the tree thats impossible. Theres no funktional digikam in the tree anymore.
Comment 4 Chris Reffett gentoo-dev Security 2012-11-28 04:19:27 UTC
File a bug upstream and link back here.
Comment 5 Stephan Karacson 2012-11-28 21:27:56 UTC
What do you exactly mean?
A bug is filed upsteam and I have already linked it in coment #2
I just wanted to keep 2.6.0.
I need to test the workaround, but as I shot the motherboard of my laptop 2 days ago I can't go after it now :-(
Comment 6 Stephan Karacson 2012-12-09 16:40:48 UTC
Workaround in the kde-bug (posted link above: ad ptp camera manually) works with 2.9.0 mostly:
Photos are downloaded but digikam keeps presenting the loadingbars.
digikam 2.6.0 was just running fine :-(
Comment 7 Andreas K. Hüttel gentoo-dev 2013-05-11 13:59:27 UTC
I'm sorry, but there's nothing we can still do here. 

(We won't keep old versions since that is complicated to maintain over time. The ebuild and patch files are still in the cvs attic, feel free to copy them to a local overlay.

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/digikam/?hideattic=0
)