Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 440458

Summary: media-gfx/splash-themes-gentoo-20101212: some elog messages should only be shown for the first install.
Product: Gentoo Linux Reporter: poletti.marco
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: trivial    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 440214    

Description poletti.marco 2012-10-31 10:58:56 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package media-gfx/splash-themes-gentoo-20101212, the following elog messages are displayed:

 * The upstream tarball for the 'Natural Gentoo' theme also contains a GRUB
 * splash image which is not installed by this ebuild.  See:
 *   http://www.kde-look.org/content/show.php?content=49074
 * if you are interested in this.

Such messages should only be displayed when the package is a new install.
These situations can be checked in the ebuild as follows:

if ! has_version 'media-gfx/splash-themes-gentoo'; then

See the tracker bug 440214 for more details.
Comment 1 Sergey Popov gentoo-dev 2013-01-20 10:40:16 UTC
+  20 Jan 2013; Sergey Popov <pinkbyte@gentoo.org>
+  +splash-themes-gentoo-20101212-r1.ebuild:
+  Revision bump: EAPI 5, QA fixes, use internal function for installation
+  instead of simple 'cp'. Show postinstallation messages only at first install,
+  wrt bug #440458