Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 440260

Summary: dev-libs/nss-3.13.6 does not respect AR
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: New packagesAssignee: Mozilla Gentoo Team <mozilla>
Severity: normal CC: vapier, vincent
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: nss-3.14-r1.patch

Description Agostino Sarubbo gentoo-dev 2012-10-30 13:08:37 UTC
ar cr Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libsectool.a Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/secutil.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/secpwd.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/derprint.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/moreoids.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/pppolicy.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/ffs.o Linux3.2_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/pk11table.o
Comment 1 Jory A. Pratt gentoo-dev 2012-10-30 13:40:25 UTC
I am not gonna sit around guessing which version you speak of. Please include a version or version range of effected package if you want to see issue fixed.
Comment 2 Agostino Sarubbo gentoo-dev 2012-10-30 14:04:05 UTC
all version affected
Comment 3 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-11-15 21:04:28 UTC
*** Bug 443454 has been marked as a duplicate of this bug. ***
Comment 4 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-11-15 21:38:42 UTC
Created attachment 329626 [details]

It doesn't respect RANLIB neither. That can be solved by appending RANLIB=$(tc-getRANLIB) to emake.

I tried to solve the AR issue appending AR=$(tc-getAR) but I get this error:

x86_64-pc-linux-gnu-ar: invalid option -- 'L'

To fix the AR issue is needed a sed command to replace 'ar' by the result of $(tc-getAR) in the file

The patch I have attached fixes both issues (AR and RANLIB).
Comment 5 SpanKY gentoo-dev 2013-03-19 22:32:21 UTC
this should be fixed in the latest version of nss/nspr