Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 439980

Summary: =app-text/psiconv-0.8.3 calls AR directly
Product: Gentoo Linux Reporter: Vicente Olivert Riera (RETIRED) <vincent>
Component: New packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: ebuild.patch
psiconv-0.8.3-fix-makefile.patch

Description Vicente Olivert Riera (RETIRED) gentoo-dev 2012-10-28 17:58:52 UTC
Created attachment 327616 [details]
ebuild.patch

Example:

# grep ^ar psiconv-0.8.3:20121026-005032.log
ar cru .libs/libcompat.a  dummy.o 
ar cru .libs/libpsiconv.a  error.o misc.o checkuid.o list.o buffer.o data.o parse_common.o parse_driver.o parse_formula.o parse_layout.o parse_image.o parse_page.o parse_simple.o parse_texted.o parse_word.o parse_sheet.o generate_simple.o generate_layout.o generate_driver.o generate_common.o generate_texted.o generate_page.o generate_word.o generate_image.o  .libs/libpsiconv.lax/libcompat.a/dummy.o 

I have attached two patches. One for fix the Makefile, and another one to upgrade the ebuild. After that, the problem is fixed.
Comment 1 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-10-28 17:59:29 UTC
Created attachment 327618 [details]
psiconv-0.8.3-fix-makefile.patch
Comment 2 Agostino Sarubbo gentoo-dev 2012-10-28 20:34:53 UTC
fixed