Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 438960

Summary: =cross-i686-pc-linux-gnu/glibc-2.15-r3 - .../work/glibc-2.15/libio/libioP.h:96 9: undefined reference to `_Unwind_Resume'
Product: Gentoo Linux Reporter: Jeroen Roovers (RETIRED) <jer>
Component: Current packagesAssignee: Gentoo Crossdev team <crossdev>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 627914    
Attachments: cross-i686-pc-linux-gnu-glibc.log.gz

Description Jeroen Roovers (RETIRED) gentoo-dev 2012-10-19 16:10:02 UTC
Created attachment 326960 [details]

Fri Oct 19 18:08:32 CEST 2012
Portage 2.2.0_alpha141 (default/linux/amd64/10.0/no-multilib, gcc-4.5.3, glibc-2.15-r3, 3.4.9-gentoo-JeR x86_64)
                        System Settings
System uname: Linux-3.4.9-gentoo-JeR-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.1
Timestamp of tree: Fri, 19 Oct 2012 15:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.21.1-r1, 2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.5.4, 4.6.2, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo JeR
ACCEPT_LICENSE="* AdobeFlash-10.1"
CFLAGS="-march=k8-sse3 -msahf --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=k8 -O2 -ggdb -pipe -Wall"
CONFIG_PROTECT="/etc /usr/lib/distcc/bin /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8-sse3 -msahf --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=k8 -O2 -ggdb -pipe -Wall"
FCFLAGS="-march=k8-sse3 -msahf --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=k8 -O2 -ggdb -pipe -Wall"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles multilib-strict news notitles parallel-fetch protect-owned sandbox sfperms sign splitdebug strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-march=k8-sse3 -msahf --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=k8 -O2 -ggdb -pipe -Wall"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="en en_GB nl"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 64bit X a52 aac aalib acl alsa amd64 amr avx bash-completion berkdb bzip2 cli cracklib crypt cups custom-cflags custom-optimization cxx dbus device-mapper dirac dmalloc dnssec dri dts dv dvd exif extras faac fortran gdbm geoip gif gsm gstreamer gtk gtk3 hwdb iconv idn ipq ipv6 jpeg jpeg2k kde kqemu kvm lcms libdnet libnet libnl lzo mjpeg mms mmx mmxext modules mp3 mpeg mpi mudflap multislot musepack ncurses network nfq nls nptl ntfsprogs ogg opengl openmp pam pcre pdf perl perl-geoipupdate playlist png pppd python qt3support quicktime readline romio rtmp schroedinger session smp speex spidermonkey spoof-source sse sse2 ssl svg symux tcpd theora threads tiff truetype unicode v4l v4l2 vaapi vcd vde vorbis vpx wavpack wmf x264 xcb xft xml xnest xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB nl" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="mga nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

cross-i686-pc-linux-gnu/glibc-2.15-r3 was built with the following:
USE="-debug -gd -hardened -multilib -profile (-selinux) -vanilla"
CFLAGS="-march=k8-sse3 -mtune=k8 -ggdb -pipe -Wall -O2 -fno-strict-aliasing"
CXXFLAGS="-march=k8-sse3 -mtune=k8 -ggdb -pipe -Wall -O2 -fno-strict-aliasing"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-10-19 16:11:19 UTC
Created attachment 326962 [details]
Comment 2 SpanKY gentoo-dev 2012-10-22 02:50:40 UTC
are you upgrading glibc ?  how exactly did you run crossdev ?
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2012-10-22 04:20:17 UTC
Upgrading from cross-i686-pc-linux-gnu/glibc-2.15-r2 to -r3.

I ran `crossdev i686-pc-linux-gnu' after reviewing version targets in /etc/portage/crossdev/i686-pc-linux-gnu/*VER - KVER was changed from 3.1 to 3.4 and LVER from 2.15-r2 to 2.15-r3.

After this, a regular `emerge -uDN world` picked up two new cross-i686 packages with changed USE flags and managed to build them quite nicely.
Comment 4 SpanKY gentoo-dev 2012-10-24 22:29:00 UTC
i just tried a similar thing but it worked for me

# crossdev i686 --l 2.15-r2
# rm /etc/portage/package.mask/cross-i686-pc-linux-gnu
# emerge =cross-i686-pc-linux-gnu/glibc-2.15-r3