Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 437950

Summary: Various bugs with enalyze from app-portage/gentoolkit-0.3.0.6-r3
Product: Portage Development Reporter: Francesco Turco <fturco>
Component: ToolsAssignee: Portage Tools Team <tools-portage>
Status: RESOLVED FIXED    
Severity: minor Keywords: InVCS
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 346443    
Attachments: Patch for fixing enalyze(1) man page

Description Francesco Turco 2012-10-11 10:06:08 UTC
I'm trying enalyze from app-portage/gentoolkit-0.3.0.6-r3 in order to understand if it can be useful for me.

The man page has several typos:
1) At the top and bottom of the man page it says ENALYZE(22), but I think it should be ENALYZE(1).
2) In the synopsis there is "[local-options]TARGET"; there should be a space between "[local-options]" and "TARGET".
3) In the description there is "Enalyze  Is  a  collection ..."; perhaps it would be better "Enalyze is a collection ..." with a lowercase "is".
4) When option "--no-pipe" is described, there is "if you do not want enalyze To detect"; a lowercase "to" is better
5) At the beginning of the MODULES section, there is "Enalyze Uses a system of modules."; "Enalyze uses ..." is better
6) Description of "analyze use" options is: "Will analyze the installed with USE flags for output results." Analyze the installed what? Packages perhaps?
7) I found three "--verebose" options in the man page; of course it should be "--verbose"
8) There are three instances of "(not Implemented yet)"; they should be "(not implemented yet)" with a lowercase "implemented"
9) Rebuild option "--excact" should be "--exact"
10) In the description of "--excact"/"--exact" there is "eg."; should be "e.g."

I usually try not to report such minor typos, but in this case I reported them because there are a lot of them.

Also, in the man page (analyze module) it says that red = disabled and blue = enabled. But when I run the analyze command with use/pkguse targets I get red flags with a "+" in front of them and blue flags with a "-" sign. But maybe since I'm new to eanalyze I didn't understand something.

analyze unmask seems to be not implemented yet since I get "!!! Error starting module. Incorrect or No TargetSpec specified!". But this is not written in the man page.

rebuild keywords instead fails with (not written in the man page):

Module action not yet available

===================================================
Traceback (most recent call last):
  File "/usr/bin/enalyze", line 39, in <module>
    enalyze.main()
  File "/usr/lib64/python3.2/site-packages/gentoolkit/enalyze/__init__.py", line 120, in main
    loaded_module.main(module_args)
  File "/usr/lib64/python3.2/site-packages/gentoolkit/enalyze/rebuild.py", line 366, in main
    query_module.run(input_args, gentoolkit.CONFIG['quiet'])
  File "/usr/lib64/python3.2/site-packages/gentoolkit/enalyze/rebuild.py", line 218, in run
    self.rebuild_keywords()
  File "/usr/lib64/python3.2/site-packages/gentoolkit/enalyze/rebuild.py", line 331, in rebuild_keywords
    pp.output.red(str(len(pkg_keys))))
UnboundLocalError: local variable 'pkg_keys' referenced before assignment

rebuild unmask fails with a simple "Module action not yet available".

module clean fails with "!!! Unknown module 'clean'". That is, yet another different kind of failure for something that has not yet been implemented. Perhaps the error output should be more standardized.

That's all. Sorry if it seems I'm too picky, but I just want to help out.

Reproducible: Always
Comment 1 Brian Dolbec gentoo-dev 2012-10-11 15:07:56 UTC
Thank you, I'll fix those later, editing man pages is a pita :(

anyway, I need to go to work now.
Comment 2 Francesco Turco 2012-10-21 18:53:33 UTC
Created attachment 327094 [details, diff]
Patch for fixing enalyze(1) man page
Comment 3 Francesco Turco 2012-10-21 18:59:47 UTC
I just attached a patch for fixing enalyze(1) man page. It's my first patch ever, so please forgive me if I did something wrong :). I fixed all numbered items from 1) to 10) except 6) as I don't know what should I write there. Also, the problem with "analyze" colors and the crash with "rebuild keywords" are still there.
Comment 4 Brian Dolbec gentoo-dev 2012-10-21 21:12:37 UTC
hmm, I actually had most of the mistakes fixed already, but hadn't pushed the commits.  I didn't get around to testing everything.

Yeah, don't worry about the color errors.  All that is being revamped for the next release.  Hopefully we will even have it configurable.  A few colors were changed for equery which changed them for enalyze too.  But the man pages didn't get updated.  

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoolkit.git;a=commit;h=df024db3a4573d89d11a59d0c05be7d4f3d7e143

I'll update it now.

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoolkit.git;a=commit;h=fa3edf538d428c5ce0589dfdc96295f640862f95

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoolkit.git;a=commit;h=beecdee864b6b0da14af3d7cc8cc05aa328ecb54

The keywords target for both analyze and rebuild modules is coded and implemented, so I didn't add (Not Implemented yet) for the keywords section.
I also hadn't removed some print messages stating it wasn't implemented.

I just fixed #6's description better.

I've also standardized a not_implemented() for consistent output from any incomplete actions.
I also fixed a number of other small copy/paste errors, where the content was not edited for the specifics of that section.
Comment 5 Brian Dolbec gentoo-dev 2012-11-07 02:36:27 UTC
These fixes have been released in gentoolkit-0.3.0.7

Thank you