Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 437458

Summary: install-amd64-minimal-20120917.iso doesn't autodetect VirtIO blockdevice/network devices
Product: Gentoo Release Media Reporter: Elias Probst <mail>
Component: InstallCDAssignee: Gentoo Release Team <releng>
Status: RESOLVED NEEDINFO    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Elias Probst 2012-10-07 00:16:51 UTC
install-amd64-minimal-20120917.iso doesn't autodetect VirtIO blockdevice/network devices.


Reproducible: Always

Steps to Reproduce:
1. Create a new qemu-kvm which uses VirtIO (default nowadays in libvirt etc.) for blockdevices and network
2. Use install-amd64-minimal-20120917.iso as install media
3. Try to access the disk (/dev/vda) or configure a NIC (eth0)
Actual Results:  
Neither the disk nor a NIC are available due to not loaded modules
virtio_blk
virtio_net

Expected Results:  
VirtIO blockdevices and NICs can be accessed instantly without manually loading the required modules.
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-12-16 06:09:55 UTC
This CD was dropped from the mirrors. Please test the latest version[1].

 [1] - http://distfiles.gentoo.org/releases/amd64/autobuilds/
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-04-29 00:03:03 UTC
No feedback.