Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 436432

Summary: sci-libs/geos-3.3.8-r1 Stabilization
Product: Gentoo Linux Reporter: Michel Boaventura <michel.boaventura>
Component: [OLD] Keywording and StabilizationAssignee: Sci-geo Project <sci-geosciences>
Status: RESOLVED FIXED    
Severity: normal CC: asturm, pgsql-bugs
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 457958    

Description Michel Boaventura 2012-09-27 18:58:22 UTC
The last stable geos version on portage (3.3.3) isn't compatible with ruby19, so it fails if I eselect ruby19 as default.

Portage already has geos versions 3.3.4 and 3.3.5, but only the last one is compatible with both ruby18 and ruby19. Since ruby19 will be the default implementation on gentoo [1], geos-3.3.5 should be unmasked.


[1] http://wiki.gentoo.org/wiki/Project:Ruby/Ruby_1.9_migration
Comment 1 Andreas Sturmlechner gentoo-dev 2012-11-24 17:19:04 UTC
Almost two months gone by - I can't find any bug related to 3.3.5.

Meanwhile, geos-3.3.6 is out: http://trac.osgeo.org/geos/browser/tags/3.3.6/NEWS
Comment 2 Andreas Sturmlechner gentoo-dev 2013-02-02 12:08:29 UTC
Update - geos-3.3.7 is out and solves bug 450998, also I found out about it building just fine against current stable php-5.4.8 in bug 455118.
Comment 3 Aaron W. Swenson gentoo-dev 2013-03-02 15:12:15 UTC
We'll shoot for a 3.3.8 stabilization.

Bug 450998 was not fixed, but will be shortly. Same with 455118.
Comment 4 Agostino Sarubbo gentoo-dev 2013-04-03 18:04:51 UTC
amd64 stable
Comment 5 Agostino Sarubbo gentoo-dev 2013-04-05 17:10:04 UTC
ppc stable
Comment 6 Agostino Sarubbo gentoo-dev 2013-04-05 18:19:21 UTC
ppc64 stable
Comment 7 Agostino Sarubbo gentoo-dev 2013-04-05 20:31:31 UTC
arm stable
Comment 8 Vicente Olivert Riera (RETIRED) gentoo-dev 2013-04-12 07:08:20 UTC
x86 stable. Last arch, closing...