Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 435316

Summary: net-misc/networkmanager-openvpn- segfaults when trying to connect due bogus gnutls-3
Product: Gentoo Linux Reporter: Michael Mair-Keimberger (iamnr3) <mmk>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Severity: normal CC: nikoli, qiaomuf, steev
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also:
Package list:
Runtime testing required: ---

Description Michael Mair-Keimberger (iamnr3) 2012-09-17 08:58:19 UTC
Yesterday i've upgraded my laptop. Now i cannon connect to my vpn anymore. It always crashes with this error in dmesg:

nm-openvpn-serv[2479]: segfault at 8 ip 00007f2b89cdfb21 sp 00007fff73ee5588 error 4 in[7f2b89c5e000+19d000]

I've tested both version in portage, and Both of them crash. Before the update i had net-misc/networkmanager-openvpn-0.8.2-r1 installed which worked.
Comment 1 Michael Mair-Keimberger (iamnr3) 2012-09-17 09:00:15 UTC
forget to include:

Portage (default/linux/amd64/10.0/no-multilib, gcc-4.5.4, glibc-2.15-r2, 3.5.3-gentoo x86_64)
System uname: Linux-3.5.3-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_L7100_@_1.20GHz-with-gentoo-2.1
Timestamp of tree: Mon, 17 Sep 2012 08:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl alsa amd64 berkdb bluetooth bzip2 cdr cli consolekit cracklib crypt cups cxx dbus dri dvd exif flac fortran gallium gdbm gif gnutls gpm graphite iconv icu ipv6 jabber jpeg kde kipi lzma mad mmx mmxext modules mp3 mudflap ncurses nls nptl opengl openmp pam pcre phonon plasma png policykit pppd qt4 readline sdl semantic-desktop session sip spell sse sse2 ssl ssse3 tcpd threads tiff truetype udev unicode v4l2 vorbis vpx xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-misc/networkmanager-openvpn- was built with the following:
USE="-gtk -test"

net-misc/networkmanager- was built with the following:
USE="bluetooth dhclient gnutls introspection ppp wext -avahi -connection-sharing -dhcpcd -doc -modemmanager -nss -resolvconf -systemd -vala -wimax"
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-26 23:10:35 UTC
Is this error still present with networkmanager-

If yes, then please report it upstream to networkmanager-openvpn authors:
and then give the bug URL here so that gentoo developers can keep track of it.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-10-26 23:14:16 UTC
Note that diagnosing a segfault is nearly impossible unless you provide a backtrace with debugging symbols.

To do so, re-emerge networkmanager and networkmanager-openvpn with -ggdb in CFLAGS and splitdebug in FEATURES (see for more details), install app-admin/abrt, and start the abrt service (/etc/init.d/abrt start). You will be able to obtain the backtrace after the crash using abrt-gui.
Comment 4 Michael Mair-Keimberger (iamnr3) 2013-02-14 08:18:46 UTC
I still have this problem, even with the latest version in portage.
I took some time, but i made an upstream bug-report now :) (with backtrace)

Comment 5 Michael Mair-Keimberger (iamnr3) 2013-02-15 13:53:19 UTC
Problem solved. Seems like the problem belongs to gnutls. Openvpn works again with latest unstable gnutls-3.1.8. See upstream bug for more information.