Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 434618

Summary: net-libs/farstream-0.1.2-r1 MAKEOPTS="-j6" - libtool: link: cannot find the library `libfarstream-0.1.la' or unhandled argument `libfarstream-0.1.la'
Product: Gentoo Linux Reporter: Mark Tomich <mstomich>
Component: [OLD] LibraryAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: binki, gnome, ondrej, orzel, shentino, tomboy64
Priority: Normal Keywords: NeedPatch
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 351559    
Attachments: errant farstream-0.1.2-r1 build.log

Description Mark Tomich 2012-09-10 18:18:46 UTC
when running:

> MAKEOPTS="-j6" emerge -a1 =net-libs/farstream-0.1.2-r1

... emerge fails with error:

> libtool: link: cannot find the library `libfarstream-0.1.la' or unhandled argument `libfarstream-0.1.la'

... otoh, the following succeeds:

> MAKEOPTS="-j4" emerge -a1 =net-libs/farstream-0.1.2-r1

NB: farstream must *not* be already installed in order to reproduce this error.

...emerge --info follows...

Portage 2.1.11.14 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r2, 3.5.3-gentoo x86_64)
=================================================================
System uname: Linux-3.5.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-2677M_CPU_@_1.80GHz-with-gentoo-2.2
Timestamp of tree: Mon, 10 Sep 2012 11:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo seden nbigaouette pentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=4096 -mtune=corei7-avx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=4096 -mtune=corei7-avx"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/seden /var/lib/layman/nbigaouette /var/lib/layman/pentoo /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cli colord consolekit cracklib crypt cups cxx dbus dri dvdr eds emboss encode evo exif fam firefox flac fortran fuse g3dvl gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nsplugin offensive ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qemu qt3support qt4 readline s3 sdl session sna spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg tcpd tftp tiff truetype udev udisks unicode upower usb vaapi virtualbox vorbis wxwidgets x264 xcb xinerama xml xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-09-11 14:24:33 UTC
Please attach the entire failing build log to this bug report.
Comment 2 Mark Tomich 2012-09-12 13:43:49 UTC
Created attachment 323610 [details]
errant farstream-0.1.2-r1 build.log
Comment 3 Olivier Crete (RETIRED) gentoo-dev 2012-09-13 14:17:32 UTC
This is an upstream makefile bug, it is already fixed in the git master. Will be in the next release
Comment 4 Ondrej Caletka 2013-10-25 07:31:14 UTC
Just hit this exact issue. Can you please fix the ebuild for 0.1 slot to disable paralel build? 

Current version of Pidgin seems to depend this particular slot, so fixing in upstream git is only a long-term solution.
Comment 5 Pacho Ramos gentoo-dev 2013-12-13 18:55:08 UTC
*** Bug 494110 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2013-12-13 18:58:14 UTC
+*farstream-0.2.3 (13 Dec 2013)
+
+  13 Dec 2013; Pacho Ramos <pacho@gentoo.org> +farstream-0.2.3.ebuild,
+  farstream-0.1.2-r1.ebuild, metadata.xml:
+  Version bump, disable parallel install for old version/slot (#434618)
+
Comment 7 Thomas Capricelli 2014-05-12 20:38:07 UTC
Hit by this also. It's still not fixed in ebuilds ???
Comments #3 says it will be fixed in next release, but several years later there's still no such release. At least in the 0.1 slot that telepathy-stream requires.
Comment 8 Pacho Ramos gentoo-dev 2014-05-15 08:06:22 UTC
+  15 May 2014; Pacho Ramos <pacho@gentoo.org> farstream-0.1.2-r1.ebuild:
+  Parallel build/installing is completely broken for old slot (#434618)
+

I thought it was only at install time, not on every phase :S
Comment 9 Gilles Dartiguelongue gentoo-dev 2015-05-01 12:52:36 UTC
Closing since workaround is applied in 0.1 ebuilds and 0.2 appears to have been fixed.