Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 434526

Summary: x11-base/xorg-server message should be updated since sets are in stable portage
Product: Gentoo Linux Reporter: Ben Longbons <b.r.longbons>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: trivial CC: blshkv, nikoli, pacho
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Ben Longbons 2012-09-10 02:13:08 UTC
Upgrading X gives this message. However, "emerge @x11-module-rebuild" although I only have portage 2.1.11.14

* Messages for package x11-base/xorg-server-1.13.0:

 * You must rebuild all drivers if upgrading from <xorg-server-1.13
 * because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.
 * You can generate a list of all installed packages in the x11-drivers
 * category using this command:
 *      emerge portage-utils; qlist -I -C x11-drivers/
 * or using sets from portage-2.2:
 *      emerge @x11-module-rebuild


Reproducible: Always
Comment 1 Nikoli 2013-05-04 15:55:49 UTC
Seems this is fixed now.
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-05-04 16:55:45 UTC
Yep, marking as fixed.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-05-04 16:55:59 UTC
*** Bug 444000 has been marked as a duplicate of this bug. ***
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-05-04 16:56:04 UTC
*** Bug 460844 has been marked as a duplicate of this bug. ***