Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 434510

Summary: gnome-base/gnome-shell-3.2.2.1: autocomplete in the run dialog does not work for non-members of group "games"
Product: Gentoo Linux Reporter: Serge Gavrilov <serge>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Serge Gavrilov 2012-09-09 20:33:59 UTC
autocomplete in the run dialog does work for non-members of group "games"

Reproducible: Always

Steps to Reproduce:
1. Install gnome-extra/gnome-games
2. Start gnome session from user, which does not belong to "games" system group
3. Alt-F2 and try autocomplete the command
Actual Results:  
autocomplete does not work. In ~/.xsession-errors you have something like


    JS ERROR: !!!   Exception was: Error: Error invoking Gio.enumerate_children_finish: Permission denied
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = '"gjs_throw"'
    JS ERROR: !!!     stack = '"("Error invoking Gio.enumerate_children_finish: Permission denied")@gjs_throw:0
([object _private_unknown_GLocalFile],[object _private_Gio_SimpleAsyncResult])@/usr/share/gnome-shell/js/misc/fileUtils.js:11
"'
    JS ERROR: !!!     message = '"Error invoking Gio.enumerate_children_finish: Permission denied"'

This is because /usr/games/bin belongs to $PATH, but it is not accessible.

I spent several hours to debug this problem :)
Comment 1 Pacho Ramos gentoo-dev 2012-09-16 09:10:07 UTC
I don't understand the problem, I guess you mean autocompletion doesn't work at all when you are not in games group (even for non games installed in plain /usr/bin), right?
Comment 2 Serge Gavrilov 2012-09-16 11:36:39 UTC
Yes, exactly. If PATH contains an unreadable direcrory, then autocomplete is broken. This is clearly upstream gnome-shell bug, but the peresence of such directory (/usr/bin/games) is gentoo specific.

I have upgraded from gnome-light to gnome and was surprised that automplete stopped working.
Comment 3 Serge Gavrilov 2012-09-16 11:37:30 UTC
sorry, I meant /usr/games/bin
Comment 4 Pacho Ramos gentoo-dev 2013-07-27 10:57:27 UTC
If still valid with 3.8, this needs to be reported to upstream
Comment 5 Pacho Ramos gentoo-dev 2013-08-23 09:33:50 UTC
looks fixed in 3.8