Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 4339

Summary: emerge --clean error [small summary]
Product: Portage Development Reporter: Johannes Findeisen <you>
Component: UnclassifiedAssignee: Daniel Robbins (RETIRED) <drobbins>
Severity: critical CC: you
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Johannes Findeisen 2002-06-30 05:10:20 UTC
hello gentoo devs, 
i have found some problems in the --clean function of portage. 
[1] when i do the following: 
#emerge -c pam-login 
i can't login after this anymore. i have fixed it with connecting to my server  
through ssh and do  
#emerge pam-login 
after that everything works fine again, but what do people with only one pc  
do? ok, well there is the boot cd, but... hmmm :-( 
[2] when i do: 
#emerge -c apache 
#emerge -c samba 
i can't start them anymore because some binaries in: 
was missing (apache, smbd and nmbd). 
[3] when i do: 
kern1 root # emerge -pc java-config 
>>> These are the packages that I would unmerge: 
    selected: 0.2.4-r1 
   protected: 0.2.4 
     omitted: none 
>>> Packages in red are slated for removal. 
>>> Packages in green will not be removed. 
you can see, that portage wants to unmerge the -r1 version, although it is the  
newest version? when i do: 
#emerge -c java-config 
#emerge -pu world 
it lists me java-config-0.2.4-r1 for updating again. 
the same is it with pam-login: 
kern1 root # emerge -pc pam-login 
>>> These are the packages that I would unmerge: 
    selected: 3.6-r2 
   protected: 3.6-r1 
     omitted: none 
>>> Packages in red are slated for removal. 
>>> Packages in green will not be removed. 
i got the same problems with some other apps too (apache i think). i have 
#emerge -C apache 
#emerge apache 
to get the newest version running. i know, that this is not the solution  
because some apps needs older libs etc. i do this only with apps like samba  
or apache where i know, that i can emerge the newest version and everything  
works fine again. 
for me it's not a problem because i'm working very carefull with the emerge -c  
function since my production server was totally shot down after i have run  
emerge -c 
i know now that this is not a stable function, so i do: 
#emerge -pc foopackage 
#emerge -c foopackage 
and i'm making a list of all packages i've cleaned on a sheet of paper - on my 
desktop, so i can emerge a package again when some things are not working 
i know, that some parts of this has been posted allready. i do this again, 
because i don't need help, but i want to give detailed information about 
things that happend and we need a solution for this. 
i've posted this to the dev list two days ago and have tested these things 
until today some times more. i hope this helps. i'll post more information 
when i found out more. 
hanez... ;-)
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-07-02 01:59:35 UTC
What version of Portage are you using?
Comment 2 Johannes Findeisen 2002-07-02 03:05:57 UTC
uuups, i have fogotten... i have installed portage 2.0.8 but it was portage 
2.0.7 where i have the problems. i didn't tried unmerging with the new 
when i now do: 
#emerge -pc java-config 
everything is ok now. but when i do: 
#emerge -pc pam-login 
it will remove 3.6-r2 instead of 3.6-r1 
i'll try cleaning some other apps in the next days and will report all errors 
Comment 3 Johannes Findeisen 2002-07-10 04:33:03 UTC
hello daniel, 
i don't know if there is a relationship between these things but i say it here 
before i forget it. i have yesterday updated my system with 
#emerge -pu world 
after i have done this i could see, that mozilla was forced to be updated 
(1.0-r2 -> 1.0-r3). so i did: 
#emerge -u world 
everything was fine so i did: 
#emerge -c mozilla 
and it safely unmerged the old version of mozilla. now when i'm making: 
#emerge rsync 
#emerge -pu world 
portage has forced the older version (1.0-r2) to be installed. i know that 
older versions sometimes are needed for other software but this is the 1.0-? 
version. isn't it the same? 
i hope it helps... 
Comment 4 Johannes Findeisen 2002-07-10 04:34:47 UTC
uuups, forgot it again. portage 2.0.11 is installed on my system. 
Comment 5 Daniel Robbins (RETIRED) gentoo-dev 2002-07-26 14:46:21 UTC
Portage 2.0.19 should have 100% working emerge clean (all these bugs have been
fixed for a while)