Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 432698

Summary: x11-base/xorg-server- - black is rendered as "lavender" (#ffddff)
Product: Gentoo Linux Reporter: Laurent G. <lauranger>
Component: [OLD] LibraryAssignee: Gentoo X packagers <x11>
Severity: normal CC: ppc, ted.tanberry
Priority: Normal    
Version: unspecified   
Hardware: PPC   
OS: Linux   
Package list:
Runtime testing required: ---

Description Laurent G. 2012-08-25 10:46:09 UTC
Upgrading from xorg-server 1.12.3 to 1.12.904 made texts that are used to be black rendered
* "lavender" (xffddff) in mozilla apps and evince menus (and all gtk apps, I guess) and most texts in these apps;
* white in gvim.
Getting back to 1.12.3 corrects everything.
Going forward with 1.12.905 brought back black in mozilla apps menus, but gvim is still white on white and this very textfield I am typing in becomes white on white too for smth like 2 seconds when I add a line.

Reproducible: Always

emerge --info
Portage 2.2.0_alpha122 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.11-gentoo-l3 ppc)
System uname: Linux-3.2.11-gentoo-l3-ppc-7447A,_altivec_supported-with-gentoo-2.2
Timestamp of tree: Sat, 25 Aug 2012 07:30:01 +0000
distcc 3.1 powerpc-unknown-linux-gnu [enabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.3.6-r1, 4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo stuff qt local
CFLAGS="-mcpu=G4 -O2 -pipe -fno-strict-aliasing -maltivec -mabi=altivec"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mcpu=G4 -O2 -pipe -fno-strict-aliasing -maltivec -mabi=altivec"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"                                                                                      
FFLAGS="-O2 -pipe"                                                                                                     
GENTOO_MIRRORS=" "                                                                                      
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                      
LINGUAS="fr fr_FR"                                                                                                     
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                               
PORTDIR_OVERLAY="/var/lib/layman/stuff /var/lib/layman/qt /usr/local/portage"                                          
USE="X Xaw3d a52 aac acl alsa altivec apache2 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cscope cups cxx dba dbus dri dts dvd dvdr emboss encode exif fam fbcon filter flac flash fortran gb gcj gd gdbm gif gnome gpm gtk gtk2 iconv ipv6 java jikes jpeg kde kdehiddenvisibility kpathsea lcms ldap libnotify mad mng modules mozdevelop mozsvg mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin objc ogg oggvorbis opengl openmp pam pango pcre pdf pdflib perl png policykit povray ppc ppds pppd private-headers python qt qt3support qt4 readline samba sasl scanner sdl session speex spell ssl startup-notification svg tcpd theora threads tiff tk truetype udev udisks unicode upower usb vorbis wmf wxwidgets xcb xinerama xml xml2 xosd xulrunner xv xvid zlib" ALSA_CARDS="snd-aoa" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi krita sheets stage words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="ati fbdev radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"                                                                                               
Comment 1 Laurent G. 2012-08-25 10:47:04 UTC
Forgot to tell I am on KDE and Qt apps are not affected.
Comment 2 Laurent G. 2012-08-25 11:20:47 UTC
I wrote that mozilla apps menus are OK in 905. Not totally. Just the menu bar entries. Submenus are still not black.

When facing the problem with 904, someone gave me the idea to play with .gtkrc-2.0 on the fora :

I found out that
menu accelerators are well displayed in the "fg[NORMAL]" color (usually black)
menu text color is kinda shifted :
#000000 gives smth around #ddddff (what I call "lavender", /o\ I had it wrong in first post)
#ff0000 gives smth around #ddffff
#ffff00 gives #ffffff
#00ff00 gives smth around #ffddff
#0000ff gives ... #0000ff !!
(I write "smth around" because I use the KDE app to catch the color and with anti-alias ...)

Evince case has a supplementary aspect : menu bar text is black at start and then becomes lavender after just hovering it. And now I found that bookmark menu in firefox shows same behaviour. Appearently smth as changed in what is used by Gtk to show/update widget enabled state.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-08-27 19:33:55 UTC
Could this be an endianness issue?
leio, mattst88: do you see this on mips too?
Comment 4 Matt Turner gentoo-dev 2012-08-27 20:46:22 UTC
(In reply to comment #3)
> Could this be an endianness issue?
> leio, mattst88: do you see this on mips too?

No mips hardware available for me to test at the moment.
Comment 5 Mart Raudsepp gentoo-dev 2012-08-29 07:20:42 UTC
My mips hardware is little endian only
Comment 6 Simon Hill 2012-10-04 23:01:56 UTC
I also experienced the lavender menu text in Firefox with KDE 4.8.5 and Firefox 10.0.7. We may be looking at two different issues here...

In my case, I had been playing with themes, particularly "Obsidian Coast" for KDE and Xfce-dusk for GTK. I found that the latter did not play well with Firefox, making the background dark but not consistently changing the font, so that I would get variously black on gray and sometimes white on white. So I switched back to oxygen and oxygen-gtk. Most things went right, but I got the lavender menu text in Firefox.

However, I easily resolved this by blowing away the .mozilla directory. Restarting Firefox after doing this restored the black text in the menu. So it looks to me like this is a Mozilla related bugs.

I didn't have any problem with evince menu text, and I don't use gvim, so I don't know whether these problems might also be related to Mozilla "remembering" something in .mozilla that it shouldn't.
Comment 7 Simon Hill 2012-10-04 23:02:36 UTC
Oh, and I experienced this problem on amd64 platform.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-04 10:59:02 UTC
Can you try with a newly created user?
Comment 9 Laurent G. 2013-01-05 12:48:00 UTC
Just tried it, by commenting part of package.mask

* emerged xorg-server- and xf86-video-ati-6.14.6-r1 (plus other drivers)
* created a fresh user
* opened new X session with that user
* fired gvim (shippest to make and launch) -> "lavender" menu

Now got back with xorg-server-1.12.4 and xf86-video-ati-6.14.6.
Comment 10 Ted Tanberry 2013-01-12 11:46:44 UTC
I have the feeling there seems to be more involved here than just xorg-server. I have tried all xorg-server versions going back to 1.11.4-r1 on my G4, and ALL of them now show this behaviour. Any ideas?
Comment 11 Laurent G. 2013-01-13 15:51:15 UTC
Even with 1.12.4  as you seems to tell ...
A Gtk bas tools that got stuck a while ago ?
I'll have to give another pass on emerge.log
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-14 10:03:08 UTC
You can check with "qlop -lu" which packages were upgraded at the time when the problem started.

It could be also pixman or cairo which is responsible.
Comment 13 Laurent G. 2013-01-18 20:47:19 UTC
Hum, cairo makes a perfect suspect : I have to keep an old 9999.
I tried to upgrade to xorg but could not have X to display anything. Getting back to working xorg+video-ati, cairo-1.12.8 crashes gtk apps. May be I should try to recompile cairo-1.12.8 with working xorg+ati-video.
Comment 14 Laurent G. 2013-01-18 22:36:00 UTC
cairo-1.12.8 can not play well with my xog -1.12.4
still trying...
Comment 15 Matt Turner gentoo-dev 2017-01-26 06:07:58 UTC
Please tell us whether this is still reproducible with modern cairo, etc.