Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 431828

Summary: app-emulation/virt-manager-0.9.4 should not depend on net-misc/spice-gtk[-gtk3]
Product: Gentoo Linux Reporter: Radu Benea <kitanatahu>
Component: New packagesAssignee: Virtualization Team <virtualization>
Status: RESOLVED FIXED    
Severity: enhancement CC: nikoli
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 420493, 420555    

Description Radu Benea 2012-08-18 09:34:14 UTC
app-emulation/virt-manager (at least version 0.9.4 - the latest currently in portage, didn't test previous versions) can successfully build and run with the spice flag even if spice-gtk was built with the gtk3 use flag so the check so
>=net-misc/spice-gtk-0.6[python,sasl?,-gtk3] should become >=net-misc/spice-gtk-0.6[python,sasl?]
Comment 1 Doug Goldstein gentoo-dev 2012-12-04 22:53:43 UTC
It should build and run fine, until you connect to a SPICE based VM and try to use the remote video over SPICE. Unless of course you're using spice-gtk-0.14-r1 or newer and then it does in fact work (which was added today).
Comment 2 Doug Goldstein gentoo-dev 2012-12-04 23:31:44 UTC
Should be fixed in the tree.