Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 431582

Summary: app-office/libreoffice-3.6.0.4 - .../work/libreoffice-core-3.6.0.4/stoc/source/defaultregistry/defaultregistry.cxx:1121:1: internal compiler error: Segmentation fault
Product: Gentoo Linux Reporter: jinleileiking
Component: [OLD] Core systemAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED DUPLICATE    
Severity: normal CC: office
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: partial build log
output of g++ cmd
full build log

Description jinleileiking 2012-08-16 00:57:03 UTC
emerge app-office/libreoffice-3.6.0.4 failed: when building stoc.

Reproducible: Always

Steps to Reproduce:
1. emerge  app-office/libreoffice-3.6.0.4
2.
3.
Actual Results:  
build failed

Expected Results:  
success
Comment 1 jinleileiking 2012-08-16 00:58:56 UTC
Created attachment 321454 [details]
partial build log
Comment 2 jinleileiking 2012-08-16 01:00:02 UTC
➜  ~ git:(master) ✗ emerge --info
Portage 2.1.10.65 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_370_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 09 Aug 2012 04:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.2.2
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-lkGentooOverlay gentoo-zh bumblebee kde-sunset rainyday
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lkGentooOverlay /var/lib/layman/gentoo-zh /var/lib/layman/bumblebee /var/lib/layman/kde-sunset /var/lib/layman/rainyday"
SYNC="rsync://gentoo.tom.com/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm gpm gtk iconv ipv6 mmx modules mudflap multilib ncurses nls nptl openmp pam pcre pppd qt3support readline session sse sse2 ssl ssse3 tcpd unicode zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 jinleileiking 2012-08-16 01:05:50 UTC
➜  ~ git:(master) ✗ epv libreoffice

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] app-office/libreoffice-3.6.0.4 [3.5.4.2-r1] USE="branding graphite gtk vba webdav xmlsec (-aqua) -binfilter -binfilterdebug -cups -dbus -eds -gnome -gstreamer -java -jemalloc -kde -mysql -odk -opengl -postgres -svg -test (-nlpsolver%) (-nsplugin%*) (-pdfimport%)" LIBREOFFICE_EXTENSIONS="presenter-console%* presenter-minimizer%* -nlpsolver% -pdfimport% -scripting-beanshell% -scripting-javascript% -wiki-publisher%" 0 kB
[ebuild     U ~] app-office/libreoffice-l10n-3.6.0 [3.5.4] USE="-offlinehelp" LINGUAS="-af -am% -ar -as -ast -be -bg -bn -bn_IN% -bo -br -brx -bs -ca -ca_XV -cs -cy -da -de -dgo -dz -el -en -en_GB -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -kok -ks -ku -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl -pt -pt_BR -ro -ru -rw -sa_IN -sat -sd -sh -si -sk -sl -sq -sr -ss -st -sv -sw_TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh_CN -zh_TW -zu" 0 kB

Total: 2 packages (2 upgrades), Size of downloads: 0 kB

 * IMPORTANT: 1 news items need reading for repository 'gentoo-zh'.
 * Use eselect news to read news items.
Comment 4 Jeroen Roovers gentoo-dev 2012-08-16 01:44:46 UTC
Comment on attachment 321454 [details]
partial build log

Please attach the entire build log to this bug report.
Comment 5 SpanKY gentoo-dev 2012-08-16 02:23:19 UTC
does it fail at the same exact place every time you try emerging it ?

if so, please run:
S=/var/tmp/portage/app-office/libreoffice-3.6.0.4/work/libreoffice-core-3.6.0.4
O=$S/solver/unxlngx6.pro && W=$S/workdir/unxlngx6.pro
mkdir -p $W/CxxObject/stoc/source/defaultregistry/ \
  $W/Dep/CxxObject/stoc/source/defaultregistry/ 
x86_64-pc-linux-gnu-g++ -DCPPU_ENV=gcc3 -DENABLE_GRAPHITE -DENABLE_GTK -DGCC \
  -DGXX_INCLUDE_PATH=/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4 \
  -DHAVE_GCC_VISIBILITY_FEATURE -DHAVE_THREADSAFE_STATICS -DLINUX -DNDEBUG \
  -DOPTIMIZE -DOSL_DEBUG_LEVEL=0 -DSUPD=360 -DUNIX -DUNX -DX86_64 -D_PTHREADS \
  -D_REENTRANT  -DBOOST_NO_0X_HDR_TYPEINDEX -Wall -Wendif-labels -Wextra \
  -fmessage-length=0 -fno-common -pipe  -DLIBO_MERGELIBS -fPIC -Wshadow \
  -Wsign-promo -Woverloaded-virtual  -Wno-non-virtual-dtor \
  -fvisibility=hidden  -fvisibility-inlines-hidden  -fno-strict-aliasing \
  -std=gnu++0x -Wno-deprecated-declarations  -DEXCEPTIONS_ON -fexceptions \
  -fno-enforce-eh-specs -O2 -march=core2 -pipe -E -dD \
  $S/stoc/source/defaultregistry/defaultregistry.cxx -o \
  $W/CxxObject/stoc/source/defaultregistry/defaultregistry.ii \
  -I$S/stoc/source/defaultregistry/  -I$S/stoc/inc -I$O/inc/external \
  -I$O/inc -I$S/solenv/inc  -I$W/UnoApiHeadersTarget/bootstrap/bootstrap

then compress & post the file as an attachment:
  $W/CxxObject/stoc/source/defaultregistry/defaultregistry.ii
Comment 6 jinleileiking 2012-08-16 06:03:00 UTC
the total build log is 7m. TOO BIG
Comment 7 jinleileiking 2012-08-16 06:10:44 UTC
Created attachment 321458 [details]
output of g++ cmd

output of 

S=/var/tmp/portage/app-office/libreoffice-3.6.0.4/work/libreoffice-core-3.6.0.4
O=$S/solver/unxlngx6.pro && W=$S/workdir/unxlngx6.pro
mkdir -p $W/CxxObject/stoc/source/defaultregistry/ \
  $W/Dep/CxxObject/stoc/source/defaultregistry/ 
x86_64-pc-linux-gnu-g++ -DCPPU_ENV=gcc3 -DENABLE_GRAPHITE -DENABLE_GTK -DGCC \
  -DGXX_INCLUDE_PATH=/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4 \
  -DHAVE_GCC_VISIBILITY_FEATURE -DHAVE_THREADSAFE_STATICS -DLINUX -DNDEBUG \
  -DOPTIMIZE -DOSL_DEBUG_LEVEL=0 -DSUPD=360 -DUNIX -DUNX -DX86_64 -D_PTHREADS \
  -D_REENTRANT  -DBOOST_NO_0X_HDR_TYPEINDEX -Wall -Wendif-labels -Wextra \
  -fmessage-length=0 -fno-common -pipe  -DLIBO_MERGELIBS -fPIC -Wshadow \
  -Wsign-promo -Woverloaded-virtual  -Wno-non-virtual-dtor \
  -fvisibility=hidden  -fvisibility-inlines-hidden  -fno-strict-aliasing \
  -std=gnu++0x -Wno-deprecated-declarations  -DEXCEPTIONS_ON -fexceptions \
  -fno-enforce-eh-specs -O2 -march=core2 -pipe -E -dD \
  $S/stoc/source/defaultregistry/defaultregistry.cxx -o \
  $W/CxxObject/stoc/source/defaultregistry/defaultregistry.ii \
  -I$S/stoc/source/defaultregistry/  -I$S/stoc/inc -I$O/inc/external \
  -I$O/inc -I$S/solenv/inc  -I$W/UnoApiHeadersTarget/bootstrap/bootstrap
Comment 8 jinleileiking 2012-08-16 06:14:52 UTC
Created attachment 321460 [details]
full build log
Comment 9 jinleileiking 2012-08-16 06:15:20 UTC
I will build again.

It failed at stoc all the time.
Comment 10 SpanKY gentoo-dev 2012-08-16 15:37:15 UTC
(In reply to comment #6)

this is what compression is for.  `xz` and be done.
Comment 11 SpanKY gentoo-dev 2012-08-16 15:37:51 UTC
Comment on attachment 321458 [details]
output of g++ cmd

i think you messed something up here.  this is a tar archive of a 10240 byte file full of zeros.  it has no actual content.
Comment 12 jinleileiking 2012-08-17 01:47:07 UTC
I have compile several time. 

Failed at different place.
Comment 13 SpanKY gentoo-dev 2012-08-17 03:13:13 UTC
please generate & attach the file as requested earlier
Comment 14 jinleileiking 2012-08-17 03:29:48 UTC
@Spanky.

It not happen at the defaultregistry.cxx I will emerge again.
Comment 15 SpanKY gentoo-dev 2012-08-17 04:21:42 UTC
sorry, i misread, i thought you said it failed at the same place every time

unfortunately, if it's random, that most likely means not a bug in gcc

try using MAKEOPTS=-j1 and removing -pipe from your CFLAGS (for this one package)

*** This bug has been marked as a duplicate of bug 20600 ***
Comment 16 jinleileiking 2012-08-30 06:40:41 UTC
@SpanKY, 

Your highness. I compile with the flags:


CFLAGS="-O2 -march=core2"
CXXFLAGS="-O2 -march=core2"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
MAKEOPTS="-j1 -l1.5"


And failed at random place. 

I check the log, found that the compile uses the '-pipe'.

I have ran memtest for one night, it is okay.

Did I need del the -pipe in FCFLAGS AND FFLAGES?

thanks.