Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 430690

Summary: net-libs/wt-3.2.2 - Aborting due to QA concerns: 4 files installed in /tmp/portage/net-libs/wt-3.2.2/image///tmp/portage/net-libs/wt-3.2.2/image/
Product: Gentoo Linux Reporter: Peter Wood <peter.wood>
Component: New packagesAssignee: No maintainer - Look at if you want to take care of it <maintainer-needed>
Severity: QA CC: 0xd34df00d, bass_dr, ostroffjh, peter.wood, proxy-maint, treecleaner
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard: Pending removal: 2016-09-20
Package list:
Runtime testing required: ---
Attachments: wt-3.3.6.ebuild

Description Peter Wood 2012-08-09 23:06:39 UTC
ebuild compiles fine, but failes installation.

Reproducible: Always

Steps to Reproduce:
1. emerge wt
Actual Results:  
error message:
>>> Completed installing wt-3.2.2 into /tmp/portage/net-libs/wt-3.2.2/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line
 * QA Notice: // installed in ${D}/${D}
 * QA Notice: //etc installed in ${D}/${D}
 * QA Notice: //etc/wt installed in ${D}/${D}
 * QA Notice: //etc/wt/wt_config.xml installed in ${D}/${D}
 * ERROR: net-libs/wt-3.2.2 failed:
 *   Aborting due to QA concerns: 4 files installed in /tmp/portage/net-libs/wt-3.2.2/image///tmp/portage/net-libs/wt-3.2.2/image/
 * Call stack:
 *, line 1261:  Called install_qa_check
 *, line  554:  Called die
 * The specific snippet of code:
 *   		die "Aborting due to QA concerns: ${INSTALLTOD} files installed in ${D}/${D}"
 * If you need support, post the output of `emerge --info '=net-libs/wt-3.2.2'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/wt-3.2.2'`.
 * The complete build log is located at '/tmp/portage/net-libs/wt-3.2.2/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/net-libs/wt-3.2.2/temp/environment'.
 * Working directory: '/tmp/portage/net-libs/wt-3.2.2/image'
 * S: '/tmp/portage/net-libs/wt-3.2.2/work/wt-3.2.2'
!!! post install failed; exiting.

Expected Results:  
ebuild should install library in the proper location

emerge --info
Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.3.8-gentoo x86_64)
System uname: Linux-3.3.8-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_870_@_2.93GHz-with-gentoo-2.1
Timestamp of tree: Thu, 09 Aug 2012 16:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage
CFLAGS="-Os -march=native -mtune=native -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-Os -march=native -mtune=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 64bit X a52 aac acl acpi alsa amd64 apache2 avi bash-completion berkdb bidi big-tables bindist bl branding bzip2 cairo cdda cddb cdparanoia cjk cli consolekit cracklib crypt css ctype cups curl custom-cflags custom-optimization cxx daemon dbus device-mapper dga dri dts dvd dvdr enca encode examples exif extensions extras fam fbcon fbcondecor ffmpeg flac fontconfig fortran freetype g3dvl gcj gconf gd gdbm gdu geoip gif gimp gnome gnome-keyring gnutls gpm graphviz gtk highlight iconv icu id3tag imlib intl ipv6 java java6 jpeg libnotify libwww lightning live loop-aes lzo mad madwifi matroska mmx mmxext modules mozdom mp2 mp3 mpeg mudflap multilib mysqli ncurses nls nptl nsplugin offensive ogg opengl openmp pam pcre pdf pdo php plotutils png policykit postgres postscript pppd python qemu-ifup qt4 quicktime raw readline rtc rtsp samba sdl secure-delete server session shout skins soap spell sqlite srt sse sse2 ssl ssse3 startup-notification svg system-libvncserver system-sqlite taglib tcpd theora threads tiff tk truetype udev unicode unlock-notify upnp urandom vcd vde vim-syntax vorbis wxWidgets x264 xanim xcb xinerama xml xml2 xmlrpc xscreensaver xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Martin Bednar 2012-08-11 20:32:16 UTC
I'm seeing the same here, on two different systems.
Comment 2 Johan Myreen 2012-09-17 06:33:36 UTC
Still the same here, too.
Comment 3 Jack 2016-08-21 22:25:38 UTC
While I don't use wt (I tried it a while ago, and only played with it) this bug is about 3.2.2, the current version in portage is 3.3.4, and 3.3.6 has been released upstream in July.  Does this bug still apply to the current version?  I don't recall getting these errors emerging 3.3.4.  When I have time (likely not for two weeks) I'll try re-emerging just to confirm.
Comment 4 David Racine 2016-08-26 05:01:30 UTC
Created attachment 444150 [details]

Jack is right, this bug is invalid.

I could take care of wt, I am not using it extensively.

Here is an ebuild for 3.3.6
Comment 5 Pacho Ramos gentoo-dev 2016-08-26 09:29:30 UTC
CCing proxy-maintainers
Comment 6 Georg Rudoy 2016-08-28 23:32:06 UTC
Works for me just fine with 3.3.4:

>>> Completed installing wt-3.3.4 into /var/tmp/portage/net-libs/wt-3.3.4/image/

 * Final size of build directory: 224848 KiB
 * Final size of installed tree: 105400 KiB

 * QA Notice: This ebuild installs into paths that should be created at runtime.
 *  To fix, simply do not install into these directories.  Instead, your package
 *  should create dirs on the fly at runtime as needed via init scripts/etc...
 *   var/run
 *   var/run/wt

This is a different issue I guess, and given that wt doesn't have any init scripts and the applications using it aren't supposed to be run as root, this is perhaps a sane thing to do.
Comment 7 Pacho Ramos gentoo-dev 2016-09-17 15:08:16 UTC
What about all the other opened bugs against this package? :/
Comment 8 Pacho Ramos gentoo-dev 2016-10-01 06:58:50 UTC