Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 429416

Summary: sys-cluster/corosync-9999 git HEAD version bump
Product: Gentoo Linux Reporter: Walter <walter>
Component: New packagesAssignee: Gentoo Cluster Team <cluster>
Status: RESOLVED WONTFIX    
Severity: normal CC: cluster, robbat2
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: git HEAD ebuild

Description Walter 2012-08-02 00:28:57 UTC
Not available in portage. Could you please add 2.0.1?

Also, 2.0.0 (released 2012-04-10) is still masked for testing.
Comment 1 Walter 2012-08-02 01:55:28 UTC
Made my own ebuild just by copying the 2.0.0 one and running ebuild corosync-2.0.1.ebuild manifest .. seemed to build and install fine. However, then I got some other information from #linux-ha suggesting git HEAD was better...

 <bobnormal> cheers. since no action on #linux-cluster, can anyone here tell me if there's a changelog available from corosync 2.0.0 -> 2.0.1? or any large known bugs? my distro (gentoo) doesn't have 2.0.1 available yet - i filed a bug to have it added - just wondering if it's worth waiting or rolling my own vs. using 2.0.0
<beekhof> bobnormal: yeah, i think you'd want it
 * beekhof knows of a couple of nasty bugs that finally got squashed
<beekhof> changelog straight from git:
 <beekhof> + Fabio M. Di Nitto (2 months ago) d7e205d: init: major cleanup  (v2.0.1)
 <beekhof> + Jan Friesse (3 months ago) 0791f44: Include ringid in processor joined log message 
 <beekhof> + Jan Friesse (3 months ago) dc5b898: Update TODO file 
 <beekhof> + Dan Clark (3 months ago) 88dd3e1: Improve testcpg to handle change of node identity 
 <beekhof> + Fabio M. Di Nitto (3 months ago) f2444ef: icmap: don't leak memory when changing ro/rw status on a key 
 <beekhof> + Fabio M. Di Nitto (3 months ago) 1dcb2d4: icmap: fix a valgrind errors (pass 1) 
 <beekhof> + Fabio M. Di Nitto (4 months ago) d2872ae: crypto init: release *_slot resource after init 
 <beekhof> + Fabio M. Di Nitto (4 months ago) b34c1e2: ipcs: allow connections only after all services are ready 
 <beekhof> actually the fixes i'm thinking of are queued for 2.0.2

... because of this, I made a new -9999 (git HEAD) ebuild. Could you please consider including this one masked?
Comment 2 Walter 2012-08-02 01:55:59 UTC
Created attachment 320006 [details]
git HEAD ebuild
Comment 3 Ultrabug gentoo-dev 2012-08-07 13:17:53 UTC
Hi Walter, I'd be happy to process this request further but so far as the mask suggests I still miss some test and feedbacks on corosync-2 series.

Would you mind sharing your experience with it ? I for one have been unable to get it working with current pacemaker-1.1.7 for instance.

What versions do you use, is there a guide somewhere you used to migrate something (I've not had the time to really dig into this enough) ?

Thanks mate
Comment 4 Walter 2012-08-07 19:50:12 UTC
git HEAD is the 2.x tree, apparently. To make the git HEAD ebuild here I just modified the latest existing 2.x ebuild to use git as a source.

There are instructions here:
http://wiki.gentoo.org/wiki/Corosync

Works on my machine!
Comment 5 Ultrabug gentoo-dev 2012-08-08 08:00:11 UTC
(In reply to comment #4)
> git HEAD is the 2.x tree, apparently. To make the git HEAD ebuild here I
> just modified the latest existing 2.x ebuild to use git as a source.
> 
> There are instructions here:
> http://wiki.gentoo.org/wiki/Corosync
> 
> Works on my machine!

I know how git HEAD ebuilds work mate but we're talking about existing clusters and a user base here so I'm afraid that saying "it works for me" won't be enough.

Can you provide the result of the following command : qlist -ICv sys-cluster
Comment 6 Walter 2012-08-08 10:11:57 UTC
testnode local.d # qlist -ICv sys-cluster
sys-cluster/cluster-glue-1.0.9-r1
sys-cluster/corosync-9999
sys-cluster/drbd-8.3.11-r1
sys-cluster/libqb-0.13.0
sys-cluster/pacemaker-1.1.7
sys-cluster/resource-agents-1.0.4-r1
testnode local.d #
Comment 7 Walter 2012-08-08 18:59:08 UTC
Re-reading your question: this is a 'from scratch' setup - I did not migrate.
Comment 8 Ultrabug gentoo-dev 2012-08-09 17:19:37 UTC
@Walter : well it still doesn't work for me, fresh setup and all... mind sharing your config plz ?

From /etc/corosync :
- corosync.conf
- service.d/pacemaker

Thank you for your help
Comment 9 Walter 2012-08-09 18:53:35 UTC
corosync.conf:

totem {
	version: 2

	crypto_cipher: none
	crypto_hash: none

	interface {
		ringnumber: 0
		bindnetaddr: 10.0.51.0
		broadcast: yes
		ttl: 1
	}
}

logging {
	fileline: on
	to_stderr: yes
	to_logfile: no
	to_syslog: yes
	debug: off
	timestamp: on
	logger_subsys {
		subsys: QUORUM
		debug: off
	}
}

quorum {
	provider: corosync_votequorum
	two_node: 1
	expected_votes: 1
}
Comment 10 Walter 2012-08-09 18:54:27 UTC
service.d/pacemaker:

service {
        # Load the Pacemaker Cluster Resource Manager
        name: pacemaker
        ver:  1
}
Comment 11 Walter 2012-08-09 18:56:07 UTC
PS. I noticed that there were some commits to the git repo yesterday, thought I doubt they would have broken things.
Comment 12 Ultrabug gentoo-dev 2012-10-29 15:34:00 UTC
I bumped corosync-2.1.0 today and got it working with pacemaker-1.1.8.

FYI, upstream confirmed that starting from corosync-2.x plugins ain't supported anymore so the service.d/pacemaker file is obsolete.

Would you mind trying it out maybe using current pacemaker-1.1.7 or the 1.1.8 ebuild in #439762

Cheers
Comment 13 Lukasz Wasikowski 2012-11-22 15:29:36 UTC
corosync 2.1.0 won't work with 	crypto_cipher and crypto_hash set to anything other than none.
Comment 14 Ultrabug gentoo-dev 2013-08-29 10:32:34 UTC
FYI

+*corosync-2.3.1 (29 Aug 2013)
+
+  29 Aug 2013; Ultrabug <ultrabug@gentoo.org> -corosync-2.3.0-r1.ebuild,
+  +corosync-2.3.1.ebuild:
+  version bump, drop old
+

and

+*pacemaker-1.1.10 (29 Aug 2013)
+
+  29 Aug 2013; Ultrabug <ultrabug@gentoo.org> -pacemaker-1.1.10_rc1.ebuild,
+  +pacemaker-1.1.10.ebuild:
+  version bump, drop old
+

Maybe they're a good combination, need feedback
Comment 15 Walter 2013-08-29 10:56:57 UTC
I will try to take a look on at this on Saturday night... however have to deal with openrc changing their network scripts and not accepting my bonding patches @ #428604 before I can construct a reasonable cluster test environment.
Comment 16 Chan Min Wai 2014-12-08 18:32:06 UTC
Just to ask..

Anyone working on this?
Comment 17 Ultrabug gentoo-dev 2014-12-10 10:17:39 UTC
(In reply to Chan Min Wai from comment #16)
> Just to ask..
> 
> Anyone working on this?

Well to me this bug should be closed now as we have a working 2.X version in tree which has been unmasked last week.

Anything in particular is problematic for you mate ?
Comment 18 Doug Goldstein (RETIRED) gentoo-dev 2015-09-06 04:17:41 UTC
From the last reply and from the state of the tree it looks like this issue should be closed. If I'm wrong please re-open.