Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 428724

Summary: sys-auth/pam_mount-2.13: ehd.c:(.text.startup+0x703): undefined reference to `crypt_init'
Product: Gentoo Linux Reporter: Dennis Schridde <devurandom>
Component: [OLD] Core systemAssignee: Hanno Böck <hanno>
Status: RESOLVED WORKSFORME    
Severity: normal CC: mattst88
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 461388    
Attachments: build.log

Description Dennis Schridde 2012-07-30 23:15:45 UTC
Relevant parts from build.log:
[…]
ERROR: ld.so: object 'libsandbox.so' from LD_PRELOAD cannot be preloaded: ignored.                                                                                                       
man: invalid option -- 'l'
[…]
ehd.o: In function `main':
ehd.c:(.text.startup+0x703): undefined reference to `crypt_init'
ehd.c:(.text.startup+0x746): undefined reference to `crypt_format'
ehd.c:(.text.startup+0x774): undefined reference to `crypt_keyslot_add_by_volume_key'
ehd.c:(.text.startup+0x786): undefined reference to `crypt_free'
collect2: error: ld returned 1 exit status
[…]

I use the pam_mount-2.13-fix-build-without-cryptsetup.patch from bug #379267.

Reproducible: Always
Comment 1 Dennis Schridde 2012-07-30 23:17:08 UTC
Created attachment 319790 [details]
build.log

Portage 2.2.0_alpha120 (default/linux/amd64/10.0/desktop/kde, gcc-4.7.1, glibc-2.15-r2, 3.5.0-gentoo x86_64)
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.1
Timestamp of tree: Sat, 28 Jul 2012 17:45:01 +0000
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.2
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo systemd local kde sunrise g-ctan
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/neatx/home"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/re
vdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check n --with-bdeps y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn
 unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/layman/systemd /var/cache/portage/local /var/cache/portage/overlays/kde /var/cache/portage/overlays/sunrise /var/lib/g-ctan"
[…]
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 SpanKY gentoo-dev 2013-03-22 02:52:59 UTC
the man stuff can probably be ignored
Comment 3 Agostino Sarubbo gentoo-dev 2013-04-13 13:31:12 UTC
Which version of sys-fs/cryptsetup are you using?
Comment 4 Matt Turner gentoo-dev 2013-08-12 05:35:07 UTC
This works for me. I've tried at various points to reproduce this and have never been successful. If you're still able to reproduce, please reopen the bug.

As it's blocking stabilization, please do so sooner rather than later if possible.
Comment 5 Dennis Schridde 2013-08-12 06:31:07 UTC
I am now using sys-auth/pam_mount[-crypt] and have not experienced the problem in a long while.
Comment 6 Matt Turner gentoo-dev 2013-08-12 07:03:24 UTC
Okay, thanks.