Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 428674

Summary: net-analyzer/ifmetric-0.3 - <pre>NETLINK: Packet too small or truncated! 32!=16!=1012</pre>
Product: Gentoo Linux Reporter: Franz Glauber Vanderlinde <franzec05>
Component: Current packagesAssignee: Netmon Herd <netmon>
Status: RESOLVED FIXED    
Severity: normal CC: spookyghost
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also: https://bugs.debian.org/514197
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: New ebuild
10_netlink_fix.patch

Description Franz Glauber Vanderlinde 2012-07-30 15:54:36 UTC
When trying to use ifmetric with kernel 3.5 on AMD64 it fails with 

<pre>NETLINK: Packet too small or truncated! 32!=16!=1012</pre>

This is probably an upstream bug, but can be fixed with proposed patch in https://bugs.launchpad.net/ubuntu/+source/ifmetric/+bug/896584

I'll create an ebuild to test building with this patch later.

Build info is fine, no errors.



Reproducible: Always

Steps to Reproduce:
1. Run the command with any interface
Actual Results:  
NETLINK: Packet too small or truncated! 32!=16!=1012

Expected Results:  
metric changed

Portage 2.2.0_alpha120 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.5.0-gentoo x86_64)
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-AMD_Phenom-tm-_II_X4_B40_Processor-with-gentoo-2.1
Timestamp of tree: Mon, 30 Jul 2012 13:30:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x11 gamerlay-stable lcd-filtering hawking sunrise belak zugaina local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10.1 RTCW-ETEULA google-chrome Oracle-BCLA-JavaSE AdobeFlash-10.3 google-talkplugin skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=amdfam10 -pipe -mabm -msse4a"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=amdfam10 -pipe -mabm -msse4a"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pt_BR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pt_BR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/gamerlay /var/lib/layman/lcd-filtering /var/lib/layman/hawking /var/lib/layman/sunrise /var/lib/layman/belak /var/lib/layman/zugaina /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aften alsa amd64 ao apache2 autoipd avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cg cgi chm chroot cleartype cli consolekit cracklib crypt ctype cups curl custom-optimization cxx dbus declarative dhcp disk-partition djvu dri dts dv dvb dvd dvdnav dvdr ebook embedded emboss encode exif extras faac fam ffmpeg filter finger firefox firefox3 flac flash fontconfig fortran fts3 fuse gallium gbm gcj gd gdbm gif gimp glib glitz gnutls gpm gtk gtk3 hal hash iconv imagemagick ipod ipv6 java javascript joystick jpeg json kde kipi lame lcms ldap libnotify librsync-bundled lm_sensors lyrics mad matroska md5sum mdnsresponder-compat mmx mmxext mng modules mozilla mp3 mp4 mpeg mplayer msn mssql mudflap multilib mysql mysqli ncurses net network nls nptl nsplugin ntfs ntfsprogs ogg openexr opengl openmp oscar pam pango pcre pdf pdo phonon php plasma plotutils png policykit posix ppds pppd pulseaudio python qt3support qt4 rar readline samba scanner sdl session simplexml smp socks5 spell sql sqlite sqlite3 sse sse2 ssl startup-notification svg tcpd tga theora threads tiff tokenizer truetype udev udisks unicode upnp upower usb v4l v4l2 vcd vdpau vim-syntax vlm vorbis webdav webkit wxwidgets x264 xcb xcomposite xinerama xml xmlreader xscreensaver xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="krita" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard synaptics wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pt_BR" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="none radeon fglrx r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Franz Glauber Vanderlinde 2012-07-30 16:20:39 UTC
Applying the pacth really fixed, attached new ebuild, I kind of suck on it, so I couldn't make use of epatch...
Comment 2 Franz Glauber Vanderlinde 2012-07-30 16:21:31 UTC
Created attachment 319738 [details]
New ebuild
Comment 3 Franz Glauber Vanderlinde 2012-07-30 16:21:52 UTC
Created attachment 319740 [details, diff]
10_netlink_fix.patch
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2012-07-30 23:43:44 UTC
Comment on attachment 319738 [details]
New ebuild

--- ifmetric-0.3.ebuild 2005-09-12 00:57:23.000000000 +0200
+++ -   2012-07-31 01:43:36.625529509 +0200
@@ -16,6 +16,7 @@
 RDEPEND=""
 
 src_compile() {
+       patch -p1 < "${FILESDIR}"/10_netlink_fix.patch
        # man page and HTML are already generated
        econf --disable-xmltoman --disable-lynx || die "econf failed"
        emake || die "emake failed"
Comment 5 Spooky Ghost 2016-11-01 10:51:11 UTC
A me-too comment - I solved the issue with the patch referred to in the launchpad bug report.  ifmetric works as expected after rebuilding.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2016-11-05 09:01:16 UTC
The patch seems to be a quite random change, but apparently it's been good enough since 2009. Applied in -r2.