Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 42845

Summary: Internal compiler error while compiling kdemultimedia 3.2.0
Product: Gentoo Linux Reporter: Johan Mellberg <johan.mellberg>
Component: [OLD] GCC PortingAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: VERIFIED WORKSFORME    
Severity: major    
Priority: High    
Version: 1.4   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: 'emerge info' output

Description Johan Mellberg 2004-02-24 23:25:44 UTC
I started 'emerge kde' yesterday and when I woke up found the following (not the separator lines...) happened during kdemultimedia compilation:

========================================================
kjloader.cpp: In constructor 'KJLoader::KJLoader()':
kjloader.cpp:137: warning: 'event' is deprecated (declared at /usr/kde/3.2/include/knotifyclient.h:186)
kjloader.cpp: In member function 'void KJLoader::switchToDockmode()':
kjloader.cpp:491: warning: 'info' is deprecated (declared at /usr/kde/3.2/include/kwin.h:427)
kjloader.cpp: In member function 'void KJLoader::slotWindowActivate(long unsigned int)':
kjloader.cpp:517: warning: 'info' is deprecated (declared at /usr/kde/3.2/include/kwin.h:427)
kjloader.cpp:522: warning: 'info' is deprecated (declared at /usr/kde/3.2/include/kwin.h:427)
kjloader.cpp: In member function 'void KJLoader::slotWindowChange(long unsigned int)':
kjloader.cpp:572: warning: 'info' is deprecated (declared at /usr/kde/3.2/include/kwin.h:427)
/usr/qt/3/include/qvaluelist.h: In member function 'QValueListNode<T>*QValueListPrivate<T>::at(unsigned int) const [with T = QString]':

Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report, with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
===================================================

... and then there's no prompt. Not sure what to do, never having reported bugs here before (although I couldn't find anything similar. Marked it as a kde bug, but might be gcc? What more info is needed?
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2004-02-25 05:07:07 UTC
Yes, your problem is gcc.  You need to set your CFLAGS back a little bit and try the compilation again. "emerge info" output would be helpful.
Comment 2 Johan Mellberg 2004-02-25 23:19:07 UTC
Created attachment 26380 [details]
'emerge info' output
Comment 3 Johan Mellberg 2004-02-25 23:36:21 UTC
Retagged and reassigned. Attachment seems odd, will edit. 
Trying to recompile with -O2 instead of -O3, hoping it will help.
Comment 4 Johan Mellberg 2004-02-25 23:44:58 UTC
Comment on attachment 26380 [details]
'emerge info' output

Gentoo Base System version 1.4.3.13
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9,
2.4.22-gentoo-r5)
=================================================================
System uname: 2.4.22-gentoo-r5 i586 Pentium MMX
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium-mmx -funroll-loops -pipe"
CHOST="i586-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=pentium-mmx -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/
http://ds.thn.htu.se/linux/gentoo http://gentoo.linux.no/
http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb crypt cups encode esd foomaticdb gdbm gif
imagemagick imlib jpeg kde ldap libg++ libwww mad mikmod mmx motif mozilla mpeg
ncurses nls oggvorbis opengl oss pam pcmcia pdflib perl png python qt quicktime
readline samba sdl slang spell ssl svga tcpd truetype x86 xml xml2 xmms xv
zlib"
Comment 5 Johan Mellberg 2004-02-25 23:46:05 UTC
Comment on attachment 26380 [details]
'emerge info' output

Ignore attachment, placed in comments instead
Comment 6 Johan Mellberg 2004-02-29 04:37:15 UTC
I have now tried CFLAGS="-O1 -march=pentium-mmx -pipe"

Compilation "proceeds" for another while, now I get:

kjloader.cpp: In constructor 'KJLoader::KJLoader()':
kjloader.cpp:137: warning: 'event' is deprecated (declared at /usr/kde/3.2/include/knotifyclient.h:186)
kjloader.cpp: In member function 'void KJLoader::switchToDockmode()':
kjloader.cpp:491: warning: 'info' is deprecated (declared at /usr/kde/3.2/include/kwin.h:427)
kjloader.cpp:497: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
kjtextdisplay.moc: In function 'void
   __static_initialization_and_destruction_0(int, int)':
kjtextdisplay.moc:28: Internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproduceable, so it is likely a hardware or OS problem
make[5]: *** [kjtextdisplay.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
The bug is not reproduceable, so it is likely a hardware or OS problem
make[5]: *** [kjloader.lo] Error 1
make[5]: Leaving directory '/var/tmp/portage/kdemultimedia-3.2.0/work/kdemultimedia-3.2.0/noatun/modules/kjofol-skin'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory '/var/tmp/portage/kdemultimedia-3.2.0/work/kdemultimedia-3.2.0/noatun/modules/kjofol-skin'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/var/tmp/portage/kdemultimedia-3.2.0/work/kdemultimedia-3.2.0/noatun/modules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/kdemultimedia-3.2.0/work/kdemultimedia-3.2.0/noatun'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/kdemultimedia-3.2.0/work/kdemultimedia-3.2.0'
make: *** [all] Error 2

!!! ERROR: kde-base/kdemultimedia-3.2.0 failed.
!!! Function kde_src_compile, Line 127, Exitcode 2
!!! died running emake, kde_src_compile:make


and then I DO get a prompt back

It says that the bug is not reproduceable, but I can reproduce it everytime by doing 'emerge kde', and it ends like above...

Note 1: I should probably mention that while the errors occur, a large amount of swap is used. 

Note 2: I have also tried with CFLAGS="-O2 -march=pentium-mmx -funroll-loops -pipe", and end up with the same errors at the exact same stage of compilation and with the same intensive memory usage right when the errors occurred (some line numbers may have been different).

Note 3: Machine is an HP Omnibook 800CT laptop, CPU is a P166MMX, memory 80MB (plus 340 MB swap), I have a 6GB disk where /dev/hda1 is a W2k NTFS partition (1.5GB), /dev/hda2 is boot and root (reiserfs, 1.3GB), /dev/hda4 is mounted as /usr (reiserfs, 3GB), and /dev/hda3 is swap. I use grub and due to some reorganization of disk space the partitions are ordered like this: 1, 4, 2, 3.

n00b help needed: I copied the above errors manually - is there a better way? There must be, but despite googling and scanning (briefly, I admit) through the gcc manual I don't know how I should go about it. Thanks...
Comment 7 Daniel Myers 2004-03-26 07:04:09 UTC
i get the same error when I emerge kdemultimedia-3.2.1, though in a different file.

emerge info:

Portage 2.0.50-r1 (default-x86-2004.0, gcc-3.3.2, glibc-2.3.2-r9, 2.6.3-gentoo-r1)
=================================================================
System uname: 2.6.3-gentoo-r1 i686 Mobile Pentium II
Gentoo Base System version 1.4.3.13
Autoconf: sys-devel/autoconf-2.58
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb crypt cups encode foomaticdb gdbm gif gnome gpm gtk gtk2 imlib jpeg kde libg++ libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell ssl svga tcpd truetype x86 xml2 xmms xv zlib"

i'll have the exact error posted as soon as I can.
Comment 8 Travis Tilley (RETIRED) gentoo-dev 2004-05-29 21:03:32 UTC
does this problem still exist with gcc 3.3.3-r5?
Comment 9 Robert Moss (RETIRED) gentoo-dev 2004-06-27 20:40:44 UTC
I think it would be reasonable to close this as a NEEDINFO, as it's been effectively dead for 3 months.
Comment 10 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-15 15:18:54 UTC
No input from reporter.
Comment 11 Johan Mellberg 2005-02-17 03:03:03 UTC
As I have moved on and no longer will be able to test this I will close it for now.