Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 428124

Summary: app-emulation/virtualbox-4.1.12: "Failed to create the VirtualBox COM object"
Product: Gentoo Linux Reporter: Beetle B. <usefuljunk>
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED WORKSFORME    
Severity: normal CC: bkohler, patrick, proxy-maint, swapon
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Beetle B. 2012-07-26 02:31:49 UTC
The title pretty much says it all. 

Portage 2.1.10.65 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 2.6.32-gentoo-r7 x86_64)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-x86_64-Intel-R-_Core-TM-_i7_CPU_870_@_2.93GHz-with-gentoo-2.1
Timestamp of tree: Wed, 25 Jul 2012 00:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.8, 2.7.3-r2, 3.1.5, 3.2.3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo multimedia xwing sage-on-gentoo kde-sunset interactive-fiction sunrise x-layman x-other
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.llarian.net/pub/gentoo http://gentoo.llarian.net/ http://gentoo.osuosl.org/ http://gentoo.gossamerhost.com http://gentoo.mirrors.tera-byte.com/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/xwing /var/lib/layman/sage-on-gentoo /var/lib/layman/kde-sunset /var/lib/layman/interactive-fiction /var/lib/layman/sunrise /var/lib/layman /var/lib/layman/other"
SYNC="rsync://rsync3.us.gentoo.org/gentoo-portage"
USE="X aac aalib acl alsa amd64 apache2 bash-completion berkdb bidi binfilter blas bzip2 cairo cdda cdr cleartype cli corefonts cracklib crypt css cups cxx dbus dga directfb djvu dri dvd dvdr emacs encode exif fbcon ffmpeg firefox fontconfig fortran ftp gdbm ggi gif gimp gnuplot gphoto2 gpm gtk handbook iconv imagemagick imap java javascript jpeg jpeg2k lapack latex lcms libcaca libmms libnotify lm_sensors lzma maildir matroska mbox midi mime mms mmx mng modules mozilla mp3 mp4 mpeg mudflap multilib ncurses nls nntp nptl nsplugin nvidia ofx ogg openexr opengl openmp pam pcre pdf png postscript pppd python qt3support qt4 quicktime raw readline rss sasl scanner sdl seamonkey semantic-desktop session smp spell sse sse2 ssl startup-notification svg tcpd theora threads tiff truetype type1 unicode usb vcd vorbis wmf x264 xcomposite xine xmp xorg xosd xscreensaver xulrunner xv xvid xvmc zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2012-08-24 10:03:07 UTC
Is this still an issue with newer virtualbox versions?
Comment 2 Beetle B. 2012-09-02 19:20:53 UTC
Yep. Seeing it in 4.1.20
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2012-09-10 14:40:21 UTC
Can you please describe briefly how to reproduce this problem?
I'd like to know when this happens (on startup of the GUI VM management window or when you start a VM) and how you start the application.
Comment 4 Beetle B. 2012-09-21 15:25:00 UTC
(In reply to comment #3)
> Can you please describe briefly how to reproduce this problem?
> I'd like to know when this happens (on startup of the GUI VM management
> window or when you start a VM) and how you start the application.

Somehow I missed your comment earlier.

Suddenly, it's working. I had uninstalled all vbox related programs and reinstalled them many times before, to no avail. Now I did it again and it just worked. 

I suspect some non-VBOX library upgrade solved it. Sorry I can't pin it down.

And to answer your question: It happened immediately upon launching VirtualBox. I didn't get to the point where I can choose the Virtual Machine. 

I suppose you could close this as a "Can't Reproduce"...

(BTW, this problem isn't that rare if you go and google the error - it's just that the fixes that worked for others (fiddling with symlinks) didn't work for me)
Comment 5 Ben Kohler gentoo-dev 2013-10-02 22:51:20 UTC
This sounds like what happens immediately after installing virtualbox-bin if you don't relog for the VBOX_APP_HOME=/opt/VirtualBox setting in /etc/env.d/90virtualbox to take effect.  If you happen to run across this problem again, please reopen the bug and also make note of what shows under "details" in the virtualbox error dialog box. 

Thanks!