Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 427936

Summary: media-libs/gupnp-dlna-0.6.6 USE=introspection - sandbox violation in /dev/dri/card0 by gst-plugin-scanner -l
Product: Gentoo Linux Reporter: Jason Lamb <jason>
Component: New packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Severity: normal CC: Nicolas.Nieswandt
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also:
Package list:
Runtime testing required: ---
Attachments: emerge --info
media-libs/gupnp-dlna-0.6.6 build log

Description Jason Lamb 2012-07-24 19:29:13 UTC
Created attachment 319110 [details]
emerge --info

Emerging media-libs/gupnp-dlna-0.6.6 fails with a sandbox violation when using the introspection USE flag. Emerges cleanly without it.
Comment 1 Jason Lamb 2012-07-24 19:29:54 UTC
Created attachment 319112 [details]
media-libs/gupnp-dlna-0.6.6 build log
Comment 2 Mike Haller 2012-09-23 11:46:52 UTC
I can confirm receiving the same error:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-22637.log"

FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /dev/dri/card0
A: /dev/dri/card0
R: /dev/dri/card0
C: /usr/libexec/gstreamer-0.10/gst-plugin-scanner -l 

>>> Failed to emerge media-libs/gupnp-dlna-0.6.6, Log file:
Comment 3 Gilles Dartiguelongue (RETIRED) gentoo-dev 2012-10-05 22:10:01 UTC
could you run:

sudo -u portage -- gst-inspect-0.10

for example and see if you have the same error ?

If so, please strace this program to see what plugin is causing problem.
Comment 4 Nicolas Nieswandt 2012-10-06 18:52:19 UTC
I got the same error message emerging gnome-extra/gnome-dvb-daemon-0.2.9 USE="nls totem".

sudo -u portage -- gst-inspect-0.10 reported no errors.

I can confirm the error with media-libs/gupnp-dlna-0.6.6.
Comment 5 Pacho Ramos gentoo-dev 2013-12-08 09:40:00 UTC
Did you try with 0.10.2?
Comment 6 Pacho Ramos gentoo-dev 2013-12-24 13:01:35 UTC
(In reply to Pacho Ramos from comment #5)
> Did you try with 0.10.2?
Comment 7 Nicolas Nieswandt 2013-12-31 14:30:26 UTC
(In reply to Pacho Ramos from comment #6)
> (In reply to Pacho Ramos from comment #5)
> > Did you try with 0.10.2?

Sorry, almost forgot. Yes, problem has vanished with 0.10.2