Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 427854

Summary: dev-ruby/rspec-core-2.10.1 USE=doc - String finished while reading (break on []) already read: ...
Product: Gentoo Linux Reporter: onip <follettoonip>
Component: [OLD] DevelopmentAssignee: Gentoo Ruby Team <ruby>
Status: RESOLVED OBSOLETE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log

Description onip 2012-07-24 08:41:48 UTC
Created attachment 319068 [details]
build.log

with the USE +doc enabled the emersion of rspec-core fails with maruku complaining.

disabling th use makes it emerge fine.

build.log attached
Comment 1 Hans de Graaff gentoo-dev 2012-07-25 06:31:19 UTC
You are using ruby19 only which we currently don't support.

It looks like maruku is broken with ruby19. Did you choose to install maruku? Can you try with another markdown provider? e.g. rdiscount or bluecloth?
Comment 2 onip 2012-07-25 07:23:55 UTC
(In reply to comment #1)
> You are using ruby19 only which we currently don't support.

dev-lang/ruby:1.9 is stable, I thought it was safe to have it as the only ruby interpreter. Could you point me to some info on that matter please?

> It looks like maruku is broken with ruby19. Did you choose to install
> maruku? Can you try with another markdown provider? e.g. rdiscount or
> bluecloth?
I didn't choose maruku as it is explicitely required by dev-ruby/sass-3.1.20 with USE doc enabled.
By the way I emerged -1 bluecloth and rspec-core picked it up (with maruku installed) and emerged fine. The only problem is that --depclean wants now to remove bluecloth.
Comment 3 Hans de Graaff gentoo-dev 2012-07-26 05:09:16 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > You are using ruby19 only which we currently don't support.
> 
> dev-lang/ruby:1.9 is stable, I thought it was safe to have it as the only
> ruby interpreter. Could you point me to some info on that matter please?

http://wiki.gentoo.org/wiki/Project:Ruby/Ruby_1.9_migration
Comment 4 Hans de Graaff gentoo-dev 2014-06-09 07:25:10 UTC
I'm closing this bug since ruby19 is now the main supported ruby and rspec 2.10 is no longer available.