Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 427688

Summary: media-video/miro-5.0.1, pre-stripped files, and revdep-rebuild keeps rebuilding due to /usr/bin/codegen.Linux-i686 (requires
Product: Gentoo Linux Reporter: Randy Tupas <rjtupas>
Component: New packagesAssignee: No maintainer - Look at if you want to take care of it <maintainer-needed>
Severity: normal CC: kripton
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: Output of emerge --info '=media-video/miro-5.0.1'

Description Randy Tupas 2012-07-23 02:52:29 UTC
I've installed unstable media-video/miro-5.0.1. During emerge, receive the following:
 * QA Notice: Pre-stripped files found:
 * /usr/bin/codegen.Linux-x86_64
 * /usr/bin/codegen.Linux-i686

If I run revdep-rebuild, it always reports:
 * Checking dynamic linking consistency
[ 9% ]  *   broken /usr/bin/codegen.Linux-i686 (requires

Revdep-rebuild will rebuild miro. Running revdep-rebuild again yields the same results.

Reproducible: Always

Steps to Reproduce:
1. Run revdep-rebuild
2. revdep-rebuild reports:broken /usr/bin/codegen.Linux-i686 (requires
3. revdep-rebuild emerges media-video/miro-5.0.1
4. Running revdep-rebuild again yields the exact same results

Expected Results:  
revdep-rebuild resolves the broken file.
Comment 1 Randy Tupas 2012-07-23 02:55:29 UTC
Created attachment 318948 [details]
Output of emerge --info '=media-video/miro-5.0.1'
Comment 2 genfool 2012-08-14 16:25:31 UTC
(In reply to comment #1)
> Created attachment 318948 [details]
> Output of emerge --info '=media-video/miro-5.0.1'

Same error here, ~amd64  someone on #gentoo replied,

" confused as to why miro is installing codegen.Linux-i686 and linking to 32bit libs, it doesn't seem to be a 32bit-only pkg"

running revdep-rebuild
 * Checking dynamic linking consistency
[ 7% ]  *   broken /usr/bin/codegen.Linux-i686 (requires

miro builds and then recieve 

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: app-emulation/emul-linux-x86-baselibs-20120520
 *  - /lib32/
 *  - /lib32/
 *      used by /usr/bin/codegen.Linux-i686 (media-video/miro-5.0.1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
Comment 3 Pacho Ramos gentoo-dev 2016-09-18 09:09:15 UTC